Bug 464380 - [RFE] The ability to copy/duplicate a vm
[RFE] The ability to copy/duplicate a vm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 20:27 EDT by Jóhann B. Guðmundsson
Modified: 2009-08-31 14:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 10:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-09-27 20:27:47 EDT
Description of problem:

The summary says it all and now with the ability to connect
to a remote server it would be a great addon if the vm could 
be exported to a remote server.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2009-01-13 04:16:06 EST
Since the feature to migrate has been implemented I guess you can use
the majority of that code to be able to Copy/Clone the VM.

To point out few scenarios in which this would be useful..

1. You need to perform benchmarking or other tests on a production VM 
hence you would just clone that VM and perform those tests on the clone
instead of the production machine.

2. You need to implement an application on a production server but want to 
see how well it integrates and test it before deploying it on the actual production server hence you would perform the installation and the tests on the clone instead.

3. You are setting up an office in another city/location and need to have exact 
same setup hence you just created 1 vm for each service ( or group of services )
copy that vm and tell the admin to fetch the from this location and deploy that vm for this service etc.. ( also useful for isp/hosting company's they would just copy a default web vm etc.. )
Comment 2 Cole Robinson 2009-08-31 10:09:10 EDT
virt-manager now supports migration and VM cloning. Cloning only works within a connection though, so you can't clone to another machine. If you have centralized storage, offline migration will accomplish this. If you want storage cloning across connections as well, that would need to be done at the libvirt level, so you should file an RFE against libvirt.

Closing as CURRENTRELEASE, since this is in virt-manager-0.8.0
Comment 3 Jóhann B. Guðmundsson 2009-08-31 14:33:21 EDT
It works perfectly filed RFE ( bug 520486 ) against libvirt supporting cloning across connections. Thanks to you and everyone involved for all your great work it's well appreciated...

Note You need to log in before you can comment on or make changes to this bug.