This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 464381 - [RFE] The ability to move a vm to another server ( live )
[RFE] The ability to move a vm to another server ( live )
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 20:44 EDT by Jóhann B. Guðmundsson
Modified: 2009-09-18 12:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 12:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Virt Manager log file... (12.79 KB, text/plain)
2009-03-09 05:30 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2008-09-27 20:44:48 EDT
Description of problem:

The summary says it all 
Usefull in many scenarious for example 
if the server needs to be taken down due to maintains. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Cole Robinson 2009-01-12 15:20:36 EST
This is currently upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/f47cf079e311

Moving to POST. This will be pulled into fedora when virt-manager is rebased.
Comment 2 Jóhann B. Guðmundsson 2009-01-13 02:24:58 EST
I guess that #464380 should be able to use the majority of this code.. 
( Clone VM ). 

Which vcs are you using git,svn,cvs so I can checkout the changes and test..
Comment 3 Fedora Update System 2009-03-04 14:21:24 EST
virt-manager-0.6.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/virt-manager-0.6.1-1.fc10
Comment 4 Fedora Update System 2009-03-05 11:29:34 EST
virt-manager-0.6.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2390
Comment 5 Jóhann B. Guðmundsson 2009-03-09 05:30:03 EDT
When trying to migrate I get... 

[Mon, 09 Mar 2009 09:12:45 virt-manager 3494] ERROR (virt-manager:156) Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 682, in control_vm_migrate
    self.emit("action-migrate-domain", self.vm.get_connection().get_uri(), self.vm.get_uuid(), host_uri)
UnboundLocalError: local variable 'host_uri' referenced before assignment
None

Migrating from F10 0.6.1-1 host to F9 0.6.1-1
Comment 6 Jóhann B. Guðmundsson 2009-03-09 05:30:43 EDT
Created attachment 334482 [details]
Virt Manager log file...
Comment 7 Cole Robinson 2009-09-18 12:33:26 EDT
Fixed in virt-manager-0.6.1-3.fc10 which is in F10. Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.