Bug 464397 - Selected text gets deleted in KDE if Input Method (SCIM) is enabled
Selected text gets deleted in KDE if Input Method (SCIM) is enabled
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
: 461373 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-28 01:37 EDT by Syam
Modified: 2008-10-06 12:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 655530 (view as bug list)
Environment:
Last Closed: 2008-10-01 02:33:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My /etc/X11/xinit/xinput.d/scim.conf (1.43 KB, text/plain)
2008-09-28 02:00 EDT, Syam
no flags Details

  None (edit)
Description Syam 2008-09-28 01:37:15 EDT
Description of problem:
I have input method enabled and set as SCIM from GNOME. When I log in to KDE, the SCIM icon is displayed in the tray (and cannot be exited). But input method does not work in KDE. So I enable Input method again within KDE, and set it to SCIM (it is initially shown as disabled). After logging back in to KDE, SCIM works.
Now, if I have some text selected in KWrite (for example), if I change window by Alt+Tab, and then come back to KWrite, the selected text gets deleted. The text gets deleted when I '*come back*' to the KWrite window.

Version-Release number of selected component (if applicable):
Problem exists with:
KDE 4.0
KDE 4.1 from updates-testing


Steps to Reproduce:
1. Enable input method as SCIM from GNOME
2. Logout and log in to KDE
3. Input method icon is in the tray, but does not work
4. Enable Input method as SCIM again from KDE
5. Logout and log in to KDE again
6. SCIM works now
7. Open a KWrite window and Dolphin window
8. Type something in KWrite and select a part fo the text
9. Press Alt+Tab to switch to Dolphin window
10. Press Alt+Tab to switch back to KWrite
11. The selected text gets deleted!
  
Additional info:
I've re-installed my Fedora 9 and this problem exists for KDE 4.0 and KDE 4.1 from updates-testing
Installed SCIM packages:
scim.i386                                1.4.7-24.fc9
scim-bridge.i386                         0.4.15-5.fc9
scim-bridge-gtk.i386                     0.4.15-5.fc9
scim-bridge-qt.i386                      0.4.15-5.fc9
scim-bridge-qt3.i386                     0.4.15-5.fc9
scim-gtk.i386                            1.4.7-24.fc9
scim-lang-malayalam.i386                 1.4.7-24.fc9
scim-libs.i386                           1.4.7-24.fc9
scim-m17n.i386                           0.2.2-3.fc9
scim-qtimm.i386                          0.9.4-10.fc9
scim-tables.i386                         0.5.8-5.fc9

I also have "swanalekha-ml.i386 v1-1.fc8" a Malayalam phonetic input method for SCIM from http://smc.org.in/node/24 (installed from RPM).
Comment 1 Syam 2008-09-28 01:58:10 EDT
Output of "imsettings-info SCIM"
-----------------------------------
Xinput file: /etc/X11/xinit/xinput.d/scim.conf
GTK+ immodule: scim-bridge
Qt immodule: scim-bridge
XMODIFIERS: @im=SCIM
XIM server: /usr/bin/scim
preferences: /usr/bin/scim-setup
auxiliary:
Short Description: SCIM
Long Description:
Is system default: TRUE
Is user default: TRUE
Is XIM server: FALSE
Comment 2 Syam 2008-09-28 02:00:22 EDT
Created attachment 317888 [details]
My /etc/X11/xinit/xinput.d/scim.conf
Comment 3 Peng Huang 2008-09-28 02:07:27 EDT
It is a bug of scim-bridge. It has been fixed in rawhide.
Comment 4 Fedora Update System 2008-09-28 02:08:08 EDT
scim-bridge-0.4.15-8.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/scim-bridge-0.4.15-8.fc9
Comment 5 Syam 2008-09-28 13:25:42 EDT
Will try it out once it makes to the updates repo. As of now, I see only 0.4.15-6.fc10 in rawhide.
Comment 6 Fedora Update System 2008-10-01 02:33:22 EDT
scim-bridge-0.4.15-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Alexander Gavrilov 2008-10-04 04:41:14 EDT
*** Bug 461373 has been marked as a duplicate of this bug. ***
Comment 8 Syam 2008-10-06 12:23:02 EDT
The problem *does not* exist with scim-bridge-0.4.15-8.fc9. Thanks a lot guys..

Note You need to log in before you can comment on or make changes to this bug.