Bug 464418 - xfig's GUI hangs
xfig's GUI hangs
Status: CLOSED DUPLICATE of bug 436998
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-28 10:40 EDT by jonne
Modified: 2008-10-06 06:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 15:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonne 2008-09-28 10:40:55 EDT
Description of problem:
After starting xfig (with a drawing or an empty drawing), if I click one of the buttons on the left (e.g., create a line, create a circel, move an object, ...), then xfig hangs. 

Version-Release number of selected component (if applicable):
I experienced the same problem with both of the following:
3.2.5-10.fc9
3.2.5-11.fc10

How reproducible:
Always the same.

Steps to Reproduce:
1. Start xfig
2. Click to draw a line
3. Note that xfig hangs
  
Actual results:
Xfig hangs.

Expected results:
To draw a line.

Additional info:
Comment 1 Hans de Goede 2008-09-28 11:10:14 EDT
Works fine for me, probably something peculiar about your setup. Do you have anything special that you can think of yourself?
Comment 2 jonne 2008-09-28 11:26:07 EDT
I really have no idea. I did update transfig a long time ago manually, so I'll just post my versions of that here, and tried to figure out what files are used using "strace xfig" as well. Don't know if it's of any help.

$ rpm -qa |grep xfig
xfig-common-3.2.5-10.fc9.i386
xfig-3.2.5-10.fc9.i386
$ rpm -qa |grep transfig
transfig-3.2.5_alpha7-0.i386


open("/etc/ld.so.cache", O_RDONLY)      = 3                                     
open("/lib/libtinfo.so.5", O_RDONLY)    = 3                                     
open("/lib/libdl.so.2", O_RDONLY)       = 3                                     
open("/lib/libc.so.6", O_RDONLY)        = 3

open("/usr/lib/libjpeg.so.62", O_RDONLY) = 3                                    
open("/usr/lib/libXpm.so.4", O_RDONLY)  = 3                                     
open("/usr/lib/libpng12.so.0", O_RDONLY) = 3                                    
open("/lib/libz.so.1", O_RDONLY)        = 3                                     
open("/usr/lib/libXi.so.6", O_RDONLY)   = 3                                     
open("/usr/lib/libXaw3d.so.7", O_RDONLY) = 3                                    
open("/usr/lib/libXmu.so.6", O_RDONLY)  = 3                                     
open("/usr/lib/libXt.so.6", O_RDONLY)   = 3                                     
open("/usr/lib/libSM.so.6", O_RDONLY)   = 3                                     
open("/usr/lib/libICE.so.6", O_RDONLY)  = 3                                     
open("/usr/lib/libXext.so.6", O_RDONLY) = 3                                     
open("/usr/lib/libX11.so.6", O_RDONLY)  = 3                                     
open("/lib/libm.so.6", O_RDONLY)        = 3                                     
open("/lib/libc.so.6", O_RDONLY)        = 3                                     
open("/lib/libuuid.so.1", O_RDONLY)     = 3                                     
open("/usr/lib/libXau.so.6", O_RDONLY)  = 3                                     
open("/usr/lib/libxcb-xlib.so.0", O_RDONLY) = 3                                 
open("/usr/lib/libxcb.so.1", O_RDONLY)  = 3                                     
open("/lib/libdl.so.2", O_RDONLY)       = 3                                     
open("/usr/lib/libXdmcp.so.6", O_RDONLY) = 3

open("/usr/lib/libXcursor.so.1", O_RDONLY) = 4                                  
open("/usr/lib/libXrender.so.1", O_RDONLY) = 4                                  
open("/usr/lib/libXfixes.so.3", O_RDONLY) = 4


These are the last few lines of strace, right before it hangs:

gettimeofday({1222615205, 23338}, NULL) = 0
poll([{fd=3, events=POLLIN, revents=POLLIN}], 1, -1) = 1
read(3, "\4\1\212J3\326s\0{\0\0\0\20\2 \4\0\0\0\0)\2\211\0\22\0\f\0\0\0\1\0", 4096) = 32
read(3, 0x887b98c, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
Comment 3 Hans de Goede 2008-09-29 03:33:23 EDT
Hmm,

You messing up transfig most likely has nothing todo with this, as xfig doesn't use transfig. The last lines of the strace probably is xfig trying to talk to the X-server. Are you running rawhide or F-9, and with which kernel and xorg driver?
Comment 4 jonne 2008-09-29 14:30:04 EDT
I'm running F-9, using kernel package kernel-2.6.26.3-29.fc9.i686.

(My system is up-to-date with 'yum update' with normal fedora repos and I do have some livna packages.)

Not sure about the xorg driver... I googled for a while, but did not figure out how to find which xorg driver I'm using. I do not have a xorg.conf file anywhere.
Comment 5 Hans de Goede 2008-09-29 14:37:03 EDT
Can you attach the output of /sbin/lspci please?
Comment 6 jonne 2008-10-02 15:36:46 EDT
Sure, here it is (I have an Acer Aspire 1640z notebook):

[root@localhost ~]# /sbin/lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)                                                 
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
06:01.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
06:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
06:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Comment 7 Hans de Goede 2008-10-02 15:52:02 EDT
Hmm, I'm afraid I have no clue as to whats causing this, so I'm going to close this as worksforme for now :(

What you could do if you want to get to the bottom of this, is boot a livecd (from usb-stick for example) and then do yum install xfig (yes you can install stuff in the live environment as long as you've got enough ram), and see if you can reproduce it then. Then we can see if this hardware specific or something with your current install.
Comment 8 jonne 2008-10-03 06:21:51 EDT
Just figured out I have the exact same problem on a different installation. I have another laptop with WinXP. Installed a Fedora 9 VMWare Image for my VMWare Player. Then I installed a bunch of packages I prefer (including KDE, Latex, Lyx, xfig, ...). And ... I see the same behavior. Whenever I click a button in xfig, it immediately hangs. 

But Yah! I figured out something that solved the problem for me.
I did a 'yum install xfig-plain' and that works.
Guess my problem had something to do with Xaw3d-1.5E-11.1.i386.

Thanks for all your help Hans,
Jonne.
Comment 9 Hans de Goede 2008-10-06 06:25:15 EDT
Jonne,

It turns out that this bug is (was) a real problem and not something peculiar with your setup. Next time when asked if you've got anything special on your system mention that you're not using gnome, but ... (kde?). I've managed to reproduce this with KDE. For the whole story see: bug 436998

A fixed Xaw3d package (which is the real culprit) is available here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=863237

Please give it a try!

*** This bug has been marked as a duplicate of bug 436998 ***

Note You need to log in before you can comment on or make changes to this bug.