Bug 464439 - emacs hangs frequently, drops characters while typing
emacs hangs frequently, drops characters while typing
Status: CLOSED DUPLICATE of bug 452849
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-28 21:32 EDT by James Ralston
Modified: 2008-09-30 13:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 13:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ralston 2008-09-28 21:32:04 EDT
As of 2008-09-28, I'm running current Rawhide, including emacs-22.2-5.fc9.

When running under X, Emacs hangs almost constantly.  I have to save my work literally every 30 seconds or so.

Also, as I type, Emacs drops characters.  E.g., I typed the above line 3 times in an Emacs window, and this is what I got:

I have toave my work literlly every 30 seconds or so.
I have to save my workliteraly every 30 seconds o so.
Ihae to save my work literlly every 30 seconds or so.

When Emacs hangs, it accepts no input and does not refresh the screen. When I strace a hung Emacs process, I see the follow system call sequence whenever I manipulate the cursor in or attempt to type in a hung Emacs windows:

select(5, [4], [], NULL, NULL)          = 1 (in [4])
--- SIGIO (I/O possible) @ 0 (0) ---
rt_sigreturn(0)                         = 1
read(4, "\34y\327\24}\0\0\0\36\1\0\0\303\3500\1\0\0\0\0\0\0\0\0\1\0\0\0\0\0\0\0"..., 4096) = 32
read(4, 0x1182ae4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(5, [4], [], NULL, NULL)          = 1 (in [4])
--- SIGIO (I/O possible) @ 0 (0) ---
rt_sigreturn(0)                         = 1
read(4, "\34y\327\24}\0\0\0\36\1\0\0\316\3500\1\0\0\0\0\0\0\0\0\1\0\0\0\0\0\0\0"..., 4096) = 32
read(4, 0x1182ae4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(5, [4], [], NULL, NULL)          = 1 (in [4])
--- SIGIO (I/O possible) @ 0 (0) ---
rt_sigreturn(0)                         = 1
read(4, "\34y\327\24}\0\0\0\30\1\0\0\5\3510\1\0\0\0\0\0\0\0\0\1\0\0\0\0\0\0\0"..., 4096) = 32
read(4, 0x1182ae4, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
[...]

Although I'm not too upset about this (this is Rawhide, after all), I wanted to make sure this problem was known...
Comment 1 James Ralston 2008-09-29 11:51:33 EDT
Additional information, in case it matters: /usr/bin/xterm will also occasionally hang in much the same way.

It might just be a coincidence, but the only applications I see this problem (xterm, emacs) are ones that still use the Core X11 font system. I've seen no issues with applications that use client-side Xft fonts.
Comment 2 sangu 2008-09-29 19:47:03 EDT
Similar issue bug 452849 ?
Comment 3 James Ralston 2008-09-30 13:46:56 EDT
After testing, yes; this is clearly the same issue as bug 452849.

*** This bug has been marked as a duplicate of bug 452849 ***

Note You need to log in before you can comment on or make changes to this bug.