Bug 464442 - gui language selection widget should get focus
gui language selection widget should get focus
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 00:37 EDT by Jens Petersen
Modified: 2008-10-01 16:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 16:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-09-29 00:37:41 EDT
Description of problem:
When one reaches the first screen in anaconda to select the install language in the GUI, anaconda should give focus to the language list not the Next button, so that one can easily choose another language with the keyboard (same is true for keyboard selection screen).  People can easily move quickly through those selection screens with Alt-N if they want to go with the defaults, whereas navigating those long lists with the mouse is awkward.

Steps to Reproduce:
1. install rawhide
2. go to language screen and try to select language with typing
3. move to keyboard screen
  
Actual results:
2. language selection widget is unfocused so typing does not work: needs focus to use
3. ditto for keyboard screen

Expected results:
2,3. expected list widgets to have focus for easy access.
Comment 1 Hans de Goede 2008-09-29 03:27:17 EDT
I'm tending towards closing this as not a bug. A significant % of users uses the default in those 2 screens, most Dutch people I know even prefer to have their Fedora in English, and although IBM once invented a Dutch keyboard 99.99 % of all Dutch computers have a standard US keyboard.

Being able to just enter through here is very convenient for the large group who is happy with the defaults, changing this to use alt+n or the mouse will be seen as a major regression, and result in lots of bug reports and time wasted on flamefests around this.

What do the other anaconda-devs think about this?
Comment 2 David Cantrell 2008-09-29 04:52:57 EDT
I think it's ok the way it is.  I mean, everyone I encounter who is selecting a different language or keyboard layout is doing so with the mouse.

Just my opinion though.
Comment 3 Andy Lindeberg 2008-09-29 13:50:48 EDT
I agree that this doesn't seem to be a problem. I think it would make less sense for us to have focus on the Next button all but a couple times than to require people to click or tab to the language and keyboard widgets. As long as the mouse and keyboard are both working fine, it's not that much of an inconvenience to hit tab before starting typing.

Note You need to log in before you can comment on or make changes to this bug.