Bug 46447 - parted doesn't mark partition active
Summary: parted doesn't mark partition active
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 46772 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-28 18:51 UTC by Tammy Fox
Modified: 2007-04-18 16:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 16:55:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tammy Fox 2001-06-28 18:51:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
After performing an installation on a machine with an IDE hard drive
on /dev/hda and choosing automatic partitioning, the / partition
was not marked active and Grub would not boot the OS.

Comment 1 Michael Fulbright 2001-07-02 15:34:20 UTC
*** Bug 46772 has been marked as a duplicate of this bug. ***

Comment 2 Gene Czarcinski 2001-07-04 09:23:53 UTC
If grub insists that it will only boot partitions marked "active", then this
will cause protblems as I have systems with many different partitions (different
systems or versions of systems) all of which I want to be able to boot.

Comment 3 Jeremy Katz 2001-07-10 06:39:07 UTC
GRUB doesn't care, only some (imho stupid) bioses care.  Made it so we emulate
the old behavior of making sure at least one partition is active per drive.


Note You need to log in before you can comment on or make changes to this bug.