Bug 464478 - Split out lm_sensor libs into a sub package
Split out lm_sensor libs into a sub package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2008-09-29 08:24 EDT by Peter Robinson
Modified: 2015-03-04 20:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 07:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-09-29 08:24:24 EDT
It would be useful to split out the lm_sensor libs into a -libs subpackage that would allow packages that use the lm_sensors libraries to install just the -libs so that it doesn't pull in extra dependencies like perl
Comment 1 Hans de Goede 2008-09-30 07:56:13 EDT
libsensors is useless with having sensors configured which requires sensors-detect. Having a system without perl is as good as impossible anyways, so splitting it up to not Require perl does not make much sense either.

Closing as not a bug.

Feel free to re-open if you think you've got strong (new) arguments to do the split anyways.
Comment 2 Peter Robinson 2008-09-30 08:06:21 EDT
I don't believe attacking my idea of having a system without perl is the best way to deal with this. I believe it should be autoconfigured by hal/dbus and all that group of stuff anyway without requiring a user to run some detection script. One reason to do this would be to allow the installation of net-snmp-utils which in turn requires net-snmp-libs which requires the above mentioned libraries but the net-snmp-utils are useful on their own with out all the other stuff installed because they can be used for snmpwalks of remote systems.
Comment 3 Hans de Goede 2008-09-30 08:26:18 EDT
(In reply to comment #2)
> I don't believe attacking my idea of having a system without perl is the best
> way to deal with this.

I'm not attacking your idea, I'm just saying it isn't a very practical idea ATM. If you really want to pursue this, please do. And when you've tackled the much bigger fish in getting a perl free system I'll gladly revisit this.

> I believe it should be autoconfigured by hal/dbus and
> all that group of stuff anyway without requiring a user to run some detection
> script.

Unfortunately, due to the way it is implemented in hardware, hw monitoring cannot be simply autodetected and configured from something like udev.

Note You need to log in before you can comment on or make changes to this bug.