Bug 464481 - clustered core log should not require block_on_error
clustered core log should not require block_on_error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cmirror-kmod (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 08:30 EDT by Milan Broz
Modified: 2013-02-28 23:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:27:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2008-09-29 08:30:08 EDT
pvmove operation tries to activate core log without block_on_error, but it fails:

Sep 29 12:51:41 bar-02 kernel: device-mapper: dm-log-clustered: Too many arguments to clustered-core mirror log type.
Sep 29 12:51:41 bar-02 kernel: device-mapper: dm-log-clustered:   2 arguments supplied:
Sep 29 12:51:41 bar-02 kernel: device-mapper: dm-log-clustered:     1024
Sep 29 12:51:41 bar-02 kernel: device-mapper: dm-log-clustered:     LVM-624BVtBB1e3EWvJzbcgAXHJu9u7bm0zZPX7k2MfUoH9ROsOq238L2spM1HQUy9Xf

(Btw note that message is wrong too - there is "few" arguments, not too many:-)

In RHEL4 it was fixed by not requiring this paramater - see constructor:

RHEL4:   <region_size> <uuid> [[no]sync] [block_on_error]
RHEL5:   <region_size> <uuid> [[no]sync] <block_on_error>

pvmove is broken - please remove block_on_error_rerquirement from RHEL5 cmirror to fix pvmove on clustered VGs.

# rpm -q kmod-cmirror cmirror lvm2 lvm2-cluster device-mapper
kmod-cmirror-0.1.15-1.el5
cmirror-1.1.23-1.el5
lvm2-2.02.40-3.el5
lvm2-cluster-2.02.40-3.el5
device-mapper-1.02.28-2.el5
Comment 3 Corey Marthaler 2008-09-30 16:04:55 EDT
There still seems to be a spot where this can still cause an error:

Sep 30 14:49:44 hayes-01 qarshd[5053]: Running cmdline: pvmove -v /dev/etherd/e1.1p7 /dev/etherd/e1.1p2
Sep 30 14:49:44 hayes-01 clogd[3219]: Too few arguments to clustered_core log type
Sep 30 14:49:44 hayes-01 clogd[3219]: Failed to create cluster log (LVM-cUg4NeO817x6DZu7eWSfVqOckiPLlcBQWlfNSBXZ8e119QSH6O1qWFa6wb2MeGo2)
Sep 30 14:49:44 hayes-01 kernel: device-mapper: table: 253:3: mirror: Error creating mirror dirty log
Sep 30 14:49:44 hayes-01 kernel: device-mapper: ioctl: error adding target to table
Sep 30 14:49:44 hayes-01 clogd[3219]: Too few arguments to clustered_core log type
Sep 30 14:49:44 hayes-01 clogd[3219]: Failed to create cluster log (LVM-cUg4NeO817x6DZu7eWSfVqOckiPLlcBQWlfNSBXZ8e119QSH6O1qWFa6wb2MeGo2)
Sep 30 14:49:44 hayes-01 kernel: device-mapper: table: 253:3: mirror: Error creating mirror dirty log
Sep 30 14:49:44 hayes-01 kernel: device-mapper: ioctl: error adding target to table

[root@hayes-01 ~]# lvs -a -o +devices
  /dev/pv_shuffle/linear: read failed after 0 of 4096 at 0: Input/output error
  LV        VG         Attr   LSize  Origin Snap%  Move               Log Copy%  Convert Devices                                                          
  LogVol00  VolGroup00 -wi-ao 72.44G                                                     /dev/sda2(0)                                                     
  LogVol01  VolGroup00 -wi-ao  1.94G                                                     /dev/sda2(2318)                                                  
  linear    pv_shuffle -wI-a-  5.00G                                                     pvmove0(0)                                                       
  [pvmove0] pv_shuffle p-C-do  5.00G               /dev/etherd/e1.1p7       0.00         /dev/etherd/e1.1p7(0),/dev/etherd/e1.1p2(0)                      
  stripe    pv_shuffle -wi---  5.00G                                                     /dev/etherd/e1.1p6(0),/dev/etherd/e1.1p5(0),/dev/etherd/e1.1p4(0)


[root@hayes-01 ~]# /usr/tests/sts-rhel5.3/lvm2/bin/lvm_rpms 
2.6.18-115.gfs2abhi.001

lvm2-2.02.40-3.el5    BUILT: Thu Sep 25 14:59:07 CDT 2008
lvm2-cluster-2.02.40-3.el5    BUILT: Thu Sep 25 15:00:54 CDT 2008
device-mapper-1.02.28-2.el5    BUILT: Fri Sep 19 02:50:32 CDT 2008
cmirror-1.1.26-1.el5    BUILT: Mon Sep 29 16:20:19 CDT 2008
kmod-cmirror-0.1.18-1.el5    BUILT: Mon Sep 29 16:20:21 CDT 2008
Comment 4 Jonathan Earl Brassow 2008-09-30 16:40:21 EDT
commit 5d6b625b06cabd8983f2b6b6275263d9408c5658
Author: Jonathan Brassow <jbrassow@redhat.com>
Date:   Tue Sep 30 15:39:54 2008 -0500

    clogd:  Further fix for bug 464481 - 'block_on_error' flag should not be required

    Last checkin cleaned up kernel module.  This checkin cleans up userspace server.
Comment 7 errata-xmlrpc 2009-01-20 16:27:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0159.html

Note You need to log in before you can comment on or make changes to this bug.