Bug 464495 - Property "Disable NAT Traversal" not supported
Property "Disable NAT Traversal" not supported
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 08:52 EDT by Brian Long
Modified: 2009-07-14 10:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:05:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Long 2008-09-29 08:52:06 EDT
Description of problem:
Since installing the latest updates (svn4022), I cannot connect with NM-vpn.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.11.svn4022.fc9.i386

How reproducible:


Steps to Reproduce:
1. VPN profile from previous release
2. Try to connect

  
Actual results:
/var/log/messages has the following:
Sep 29 08:43:15 brilong-lnx NetworkManager: <info>  Starting VPN service 'org.freedesktop.NetworkManager.vpnc'...
Sep 29 08:43:15 brilong-lnx NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' started (org.freedesktop.NetworkManager.vpnc), PID 3662
Sep 29 08:43:15 brilong-lnx NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Sep 29 08:43:15 brilong-lnx NetworkManager: <info>  VPN plugin state changed: 1
Sep 29 08:43:19 brilong-lnx NetworkManager: <info>  VPN plugin state changed: 3
Sep 29 08:43:19 brilong-lnx NetworkManager: <info>  VPN connection 'foo' (Connect) reply received.
Sep 29 08:43:19 brilong-lnx NetworkManager: <WARN>  nm_vpn_connection_connect_cb(): VPN connection 'foo' failed to connect: 'property 'Disable NAT Traversal' invalid or not supported'.
Sep 29 08:43:19 brilong-lnx NetworkManager: <WARN>  connection_state_changed(): Could not process the request because no VPN connection was active.
Comment 1 Dan Williams 2008-09-29 18:41:03 EDT
Ugh, not good.  It's supported in the UI, edit the VPN connection and pick "Disabled" for NAT Traversal in the VPN tab for that connection.  Any idea what should be the default?  Cisco UDP?
Comment 2 Brian Long 2008-09-30 07:55:49 EDT
Dan, this VPN profile worked fine in the previous F9 release of NetworkManager-vpnc.  I had NAT traversal already set to disabled and it complains as above that the property is not supported.  I'm running the following RPMS:

vpnc-0.5.1-6.fc9.i386

wpa_supplicant-0.6.3-6.fc9.i386

NetworkManager-0.7.0-0.11.svn4022.fc9.i386
NetworkManager-glib-0.7.0-0.11.svn4022.fc9.i386
NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9.i386
NetworkManager-gnome-0.7.0-0.11.svn4022.fc9.i386

It appears that something changed in NetworkManager and didn't get changed in NetworkManager-vpnc (or the opposite).  Note the error:
nm_vpn_connection_connect_cb(): VPN connection 'foo' failed to connect: 'property 'Disable NAT Traversal' invalid or not supported'.

It sounds like the property used to be "Disable NAT Traversal".  Now the property is "NAT Traversal" with choices of Disabled, Cisco-UDP or NAT-T.
Comment 3 Brian Long 2008-10-06 10:33:22 EDT
Prior to the NM updates listed in the previous comment, my VPN connection worked and it had the following property:
/system/networking/connections/12/vpn/Disable@32@NAT@32@Traversal

It appears this property is now invalid, but there was not a transition to get rid of that property or migrate the property to the new name:
/system/networking/connections/5/vpn/NAT@32@Traversal@32@Mode

I created a new VPN connection with the same gateway and it works well.  I believe NM needs to be enhanced to migrate obsolete properties to the new properties instead of erroring out.
Comment 4 Dan Williams 2008-10-06 11:33:56 EDT
vpnc hasn't supported the "Disable NAT Traversal" command since 0.3 so I'm not sure NAT traversal was ever disabled for you in either F8 or F9.  What _might_ have happened was that with the latest updates, the default NAT traversal mode switched from "Cisco" to "NAT-T".

But you're correct, that option should be migrated if present, it's a bug that it is not correctly interpreted.
Comment 5 Bug Zapper 2009-06-09 22:50:15 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-07-14 10:05:58 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.