This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 464642 - VMs go into Zombie state when xend is restarted
VMs go into Zombie state when xend is restarted
Status: CLOSED DUPLICATE of bug 280611
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 15:36 EDT by Will Nguyen
Modified: 2009-12-14 16:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 12:31:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xend log file (13.15 KB, application/octet-stream)
2008-11-11 21:53 EST, zhq527725
no flags Details
VM config file (564 bytes, text/plain)
2008-11-11 21:58 EST, zhq527725
no flags Details

  None (edit)
Description Will Nguyen 2008-09-29 15:36:01 EDT
Description of problem:
If a VM is running when xend is restarted, and the VM is then shutdown, the VM will go to Zombie state.

Version-Release number of selected component (if applicable):
- Red Hat Enterprise Linux Server release 5.2 (Tikanga)
- 2.6.18-92.el5xen

How reproducible:
100%

Steps to Reproduce:
1. Install a new RH5.2 (64-bit) host with Xen
2. Use virt-manager to create a new VM
3. Start the VM from virt-manager
4. Run "/sbin/service xend restart"
5. Shutdown the VM from virt-manager

Actual results:
The virt-manager GUI will display the VM constantly switching between the on and off state. The "virsh list" command will show the VM in Zombie state.

Expected results:
The VM should shutdown successfully without entering into a Zombie state.

Additional info:
Comment 1 Jiri Denemark 2008-11-11 09:15:15 EST
Hello Will,

I need more information as I was not able to reproduce this bug. What is the type of virtual machine you are creating? Is it a fully virtualized machine or a paravirtualized one? What operating system is running inside the VM?

Could you, please, also share exact version number of xen package?

In addition, VM's configuration file (/etc/xen/VM_name) and messages written to /var/log/xen/xend.log and /var/log/xen/xend-debug.log after you tell virt-manager to shutdown the VM would be really helpful. Please, send these as attachments to this bug.

Thanks

Jiri Denemark
Comment 2 zhq527725 2008-11-11 21:50:53 EST
Hi Jiri,

Here are the information you need, I do this on behalf of Will.

Type of VM: Fully virtualized machine

Guest OS: Red Hat Enterprise Linux AS release 4 (Nahant Update 6) 64bits

Version number of Xen package:
$ rpm -qa | grep xen 
kernel-xen-devel-2.6.18-92.el5
xen-libs-3.0.3-64.el5
kernel-xen-2.6.18-92.el5
xen-libs-3.0.3-64.el5
xen-devel-3.0.3-64.el5
xen-devel-3.0.3-64.el5
xen-3.0.3-64.el5
kernel-xen-devel-2.6.18-92.1.13.el5
kernel-xen-2.6.18-92.1.13.el5

Output of "virsh list" when this problem occurs:
$ virsh list
 Id Name                 State
----------------------------------
  0 Domain-0             running
  2 Zombie-rhel46_full_virt64 no state

I have checked there are no any messages written to /var/log/xen/xend-debug.log when this problem occurs, I will attach VM's configuration file and /var/log/xen/xend.log later.

Regards,
Qian
Comment 3 zhq527725 2008-11-11 21:53:23 EST
Created attachment 323287 [details]
Xend log file
Comment 4 zhq527725 2008-11-11 21:58:59 EST
Created attachment 323288 [details]
VM config file
Comment 5 zhq527725 2008-11-11 22:03:28 EST
In the attached Xend.log, you see I started a VM at 20:33:20, restarted Xend service at 20:36:02, and shutdown the VM at 20:37:57, then this problem occured.

Regards,
Qian
Comment 6 Jiri Denemark 2008-11-12 12:31:50 EST
This bug is a duplicate of an older bug. I'm closing this one...

*** This bug has been marked as a duplicate of bug 280611 ***

Note You need to log in before you can comment on or make changes to this bug.