Bug 46469 - memory alloc (3475134059 bytes) returned NULL" on some RPM operations
Summary: memory alloc (3475134059 bytes) returned NULL" on some RPM operations
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL: http://download.babbotec.org/rpmdb.ta...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-28 22:22 UTC by Dominik Geisel
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 22:22:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dominik Geisel 2001-06-28 22:22:10 UTC
as written in the mailing list, I cannot "rpm -qa" any more because I get

 the error "memory alloc (3475134059 bytes) returned NULL"





How Reproducible:happens always





Steps to Reproduce:

1. enter rpm -qa

2. 

3. 



Actual Results:





Expected Results:





Additional Information:

Comment 1 Jeff Johnson 2001-06-30 18:17:33 UTC
FIxed in rpm-4.0.3-0.55. Meanwhile, your rpm/Packages and my rebuilddb
log are at
	ftp://people.redhat.com/jbj/rpmdb3-46469-FIX.tar.gz
Do the following
	cd /var/lib/rpm
	mv Packages Package-SAVE
	cd ..
	tar xzvf rpmdb3-46469-FIX.tar.gz
	rpm --rebuilddb -vv

Comment 2 Juan Carlos Orrego 2001-08-06 21:35:56 UTC
I have the same problem : memory alloc (1768337276 bytes) returned NULL, when
trying to make any rpm operation (rpm --rebuilddb, kpackage, rpm -qa). i try to
find the newest package (rpm-4.0.3-0.55) and i couldnt. what shoul i do now?
there is anyone fixing Packeges or what?
Thanks


Note You need to log in before you can comment on or make changes to this bug.