Bug 464700 - API Errata addition violates constraint SPACEWALK.RHN_ERRATAFILE_EID_FILE_UQ
API Errata addition violates constraint SPACEWALK.RHN_ERRATAFILE_EID_FILE_UQ
Status: CLOSED DUPLICATE of bug 455034
Product: Spacewalk
Classification: Community
Component: API (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Red Hat Satellite QA List
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-09-29 18:20 EDT by Jeremy Mueller
Modified: 2012-03-06 03:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-03 17:14:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Perl script to recreate the constraint error. (941 bytes, text/plain)
2008-09-29 18:20 EDT, Jeremy Mueller
no flags Details
The relevant catalina.out for this. (37.06 KB, text/plain)
2008-09-29 18:23 EDT, Jeremy Mueller
no flags Details

  None (edit)
Description Jeremy Mueller 2008-09-29 18:20:53 EDT
Created attachment 318015 [details]
Perl script to recreate the constraint error.

Description of problem:

If you have multiple archs of an RPM in Spacewalk and try to add an errata through the API for them, you receive a SPACEWALK.RHN_ERRATAFILE_EID_FILE_UQ constraint violation error.


Version-Release number of selected component (if applicable):



How reproducible:

Always.


Steps to Reproduce:
1. Upload two variations of the same RPM (for my example I was testing kexec-tools-1.102pre-21.el5_2.2.i386.rpm and kexec-tools-1.102pre-21.el5_2.2.x86_64.rpm).
2. Locate the package IDs for these two packages.
3. Use the XMLAPI to upload an errata for these packages (see the attached test script errata_test_case.pl).
  
Actual results:

"500 Internal Server Error" on command line and "ORA-00001: unique constraint (SPACEWALK.RHN_ERRATAFILE_EID_FILE_UQ) violated" message in catalina.out.

Expected results:

An errata added to the database that refers to both packages.

Additional info:

To verify that the problem is the constraint violation, you can disable the constraint in Oracle (alter table RHNERRATAFILE disable constraint RHN_ERRATAFILE_EID_FILE_UQ;) and re-run the test script.
Comment 1 Jeremy Mueller 2008-09-29 18:23:13 EDT
Created attachment 318017 [details]
The relevant  catalina.out for this.
Comment 2 Justin Sherrill 2008-11-03 17:14:19 EST

*** This bug has been marked as a duplicate of bug 455034 ***

Note You need to log in before you can comment on or make changes to this bug.