Bug 464707 - Wireless fails to connect to encrypted network using 4965AGN card.
Wireless fails to connect to encrypted network using 4965AGN card.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 19:24 EDT by Colby Hoke
Modified: 2008-12-12 13:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 13:34:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is output of "tail -f /var/log/messages > test.txt" for 2 failed attempts (11.61 KB, text/plain)
2008-09-29 19:24 EDT, Colby Hoke
no flags Details

  None (edit)
Description Colby Hoke 2008-09-29 19:24:52 EDT
Created attachment 318024 [details]
This is output of  "tail -f /var/log/messages > test.txt" for 2 failed attempts

Description of problem:

Wireless will not connect to encrypted network in current rev of kernel (2.6.26.3-29.fc9.x86_64). It will see the available networks and attempt to connect to one that is encrypted (with WEP or WPA) and fail. After fail, most times that wireless network will not be visible again until reboot.

This is using a  Intel PRO/Wireless 4965 AGN Network Connection (rev 61) card.

There is no problem connecting to open networks, however.

Also, this problem does not occur in previous kernels (tested on 2.6.25-14.fc9.x86_64).


Version-Release number of selected component (if applicable):

2.6.26.3-29.fc9.x86_64

How reproducible:

Any time I try to connect to encrypted wifi networks. Always.

Steps to Reproduce:

1. Boot.
2. Try to connect to WEP or WPA wifi network via NetworkManager
3. fail at connect
  
Actual results:

No wifi connection on encrypted networks.

Expected results:

Working wifi connection on encrypted networks.

Additional info:
Comment 1 Colby Hoke 2008-09-30 01:28:45 EDT
Update: I'm not being able to consistently connect to *any* network- encrypted or not.
Comment 2 John W. Linville 2008-09-30 10:26:46 EDT
Have you tried a rawhide kernel on that box?
Comment 3 Colby Hoke 2008-09-30 11:40:30 EDT
I've tried the two mentioned and 2.6.26.5-47.fc9.x86_64. I've noticed more and more that I can connect to WPA on first boot with few problems. Never can connect to WEP in current kernel. 

If I turn off the network, I can't reconnect to wireless on any kernel.

Another thing I noticed is if I flip the wireless switch on the side of the XPS M1330, I can never get back to the wireless and, many times, I have a kernel failure-it lets me know it's sending a kernel report.

I've tried reinstalling a few times, just to be sure, but the problem is persistent.
Comment 4 John W. Linville 2008-09-30 11:52:53 EDT
Please try a rawhide kernel:

   yum --enablerepo=development install kernel

Does that behave differently w.r.t. wireless?
Comment 5 John W. Linville 2008-09-30 11:56:43 EDT
Also, since you are using iwl4965, you might try a line like this in /etc/modprobe.conf:

   options iwl4965 swcrypto=1

After adding that, either reboot or execute (as root) 'modprobe -r iwl4965 ; modprobe iwl4965'.  Does the driver behave any differently with swcrypto?
Comment 6 Colby Hoke 2008-09-30 18:33:49 EDT
Fedora does not boot under the newly installed kernel. (2.6.27-0.370.rc8.fc10.x84_64).

Second approach seems to work.. but not if i use the wif hardware cutoff switch - will try a few more reboots and see what happens.
Comment 7 Colby Hoke 2008-09-30 19:31:24 EDT
Just did a fresh install. Updated everything to latest version in stable repo.

added options and rebooted->kernel panic when connecting to wifi point

Hard reboot -> connected automatcally to my WPA wifi.
Disabled network via Network Manager. It reconnected after a while by itself.

So, no problems at the moment. Will update tomorrow when I get to work and use our WEP.


That is, unless I have any more troubles tonight - going to try some unencrypted networks around town.
Comment 8 Colby Hoke 2008-09-30 19:45:54 EDT
Okay it's totally unreliable and unpredictable. Would I be better off just buying a 3945 card?
Comment 9 Colby Hoke 2008-10-01 01:26:48 EDT
So, did another fresh install of F9. It saw and connected to my WPA router immediately. I updated all that I could.

Reboot into new kernel.

I then went in and added the previously mentioned lines to modprobe.conf

I also added pci=routeirq to /grub/menu.lst as recommended on #fedora

I was able to connect to WPA wireless. Disable wireless for a few minutes and enable - connected.
 Did this three times and it stopped connecting. It seems like it's sending the wrong password to it after something goes wrong.

I decided to do a screencast of what's happening when it's not connecting. I also look through my /var/log/messages file in this screencast and you can see there's quite a few times when it doesn't connect that I get an error Wireless Event too big. This always happens.

Cast is at www.colbyhoke.com/wireless.ogg - very small, only 6 megs

Any ideas? If I reboot, I'm about 80% success rate on immediate connection, though there are some times where I have to hit cancel on Wireless Network Secrets Required and then try to reconnect and type in the pass again. That seldom works, but its enough to try it every times.
Comment 10 John W. Linville 2008-10-01 15:23:59 EDT
Not sure if the 'Wireless Event too big' message are really a problem.  I'm told that wpa_supplicant doesn't really need to receive those events anyway.  Anyway, that is caused by the amount of information elements sent by the AP, which shouldn't be likely to change based on the kernel verion. :-)


I'm going to Cc: Dan Williams, in case he sees something in the NM or wpa_supplicant interactions that is helpful.
Comment 11 John W. Linville 2008-10-03 15:41:18 EDT
Please see bug 458972 comment 11...
Comment 12 John W. Linville 2008-10-23 13:42:00 EDT
Were you able to connect by running wpa_supplicant configured as described in bug 458972 comment 11?
Comment 13 Colby Hoke 2008-10-23 13:55:48 EDT
I put in another wireless card, but I will try to get some time this weekend to switch to switch them out and test that.
Comment 14 Rob Wilmoth 2008-11-01 19:04:33 EDT
I'm running the iwl4965 driver mentioned here and I've been actually getting lack of success on both WEP and WPA networks. I've tried the options listed in comment #5 and will test out the configuration listed in comment #12 tonight.
Comment 15 John W. Linville 2008-11-11 12:28:11 EST
Are you attempting to use a .11n AP?  Do you see different behavior when using .11g APs?
Comment 16 John W. Linville 2008-12-10 14:19:37 EST
Is this still occuring with current F10 kernels?
Comment 17 Colby Hoke 2008-12-10 15:38:59 EST
It seems to be working fine now. I've had a couple disconnects, but I'm not convinced there's much of a problem now. I'm using both cards in the laptop now and think they might be conflicting with each other  when it does fail.

Note You need to log in before you can comment on or make changes to this bug.