Bug 464751 - Feature: accept --no-foo style options
Feature: accept --no-foo style options
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 04:36 EDT by Ed Avis
Modified: 2009-01-21 15:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 07:50:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2008-09-30 04:36:05 EDT
rpm has many negated long options such as --nosignature, --nodigest, --nodeps etc.

The commonly used style in many programs from GNU and elsewhere is to hyphenate these, as --no-signature, --no-digest, --no-deps and so on.

It would be a good idea for rpm to accept these forms as well as the ones without hyphen.  (And ideally to use the --no-foo style in documentation and help messages, since it's a bit more readable, but this is a matter of opinion.)
Comment 1 Jeff Johnson 2008-09-30 09:17:33 EDT
If you really want this to happen, please submit a RFE to <popt-devel@rpm5.org> to
handle bit set and/or clear based on a "no-" option prefix.
Comment 2 Ed Avis 2008-10-05 07:02:44 EDT
Feature request sent upstream: <http://thread.gmane.org/gmane.comp.package-management.rpm.popt/1>.

Is the rpm5 popt library the upstream for Fedora, though?
Comment 3 Panu Matilainen 2009-01-08 07:50:39 EST
That's the upstream popt for Fedora, yes.

But popt aside, going this way would just create huge compatibility rift wrt existing documentation including books in and out of print, and/or crazy amount of redundancy (rpm has way too many switches as it is).

WONTFIX from rpm POV.
Comment 4 Jeff Johnson 2009-01-21 15:35:23 EST
A POPT_ARGFLAG_TOGGLE has been added, will be in popt-1.15 when released.

Too bad that rpm.org isn't going to use. Every additional option added to rpm
starts to diverge from doco. I fail to see how making all existing disablers in RPM
which are currently written in doco as
    --nofoo
and (if POPT_ARGFLAG_TOGGLE is used) are now displayed as
    --[no]foo
with the additional benefit that
    --foo
has the opposite effect causes a "crazy amount of redundancy."

And whether RPM has too many switches (it does) is irrelevant. Users
want "features" which forces additional options into RPM, usually rather unimportant
disablers like --noposttrans.

Thanks for the RFE.

Note You need to log in before you can comment on or make changes to this bug.