Bug 464757 - Review Request: openssl-tpm-engine - OpenSSL engine for TSS API
Review Request: openssl-tpm-engine - OpenSSL engine for TSS API
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rajiv Andrade
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-DEADREVIEW
  Show dependency treegraph
 
Reported: 2008-09-30 06:21 EDT by David Woodhouse
Modified: 2012-06-29 18:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 18:01:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2008-09-30 06:21:58 EDT
Spec URL: http://david.woodhou.se/openssl-tpm-engine.spec
SRPM URL: http://david.woodhou.se/openssl-tpm-engine-0.4.1-1.fc10.src.rpm
Description: This package provides an OpenSSL "engine" which lets OpenSSL handle keys stored in a TPM.
Comment 1 David Woodhouse 2008-09-30 06:25:57 EDT
I am probably a poor choice of maintainer for this package. Does anyone with more clue want it?
Comment 2 David Woodhouse 2008-09-30 09:32:43 EDT
New patch to store TSS key 'blobs' in a text file rather than in a separate binary-only file, so that users can have a single '.pem' file with their identity, as they can without the TPM.

If the trousers-tech list ever accepts my subscription attempt, I'll post it there.

http://david.woodhou.se/openssl-tpm-engine-privkey-pem.patch

Spec URL: http://david.woodhou.se/openssl-tpm-engine.spec
SRPM URL: http://david.woodhou.se/openssl-tpm-engine-0.4.1-2.fc10.src.rpm
Comment 3 Rajiv Andrade 2008-10-01 10:04:03 EDT
Hi David,

I can't see you subscription request to trousers-tech neither a post from you awaiting approval, did I miss something?

Thanks
Comment 4 David Woodhouse 2008-10-01 11:33:35 EDT
I've just tried again, at 
https://lists.sourceforge.net/lists/subscribe/trousers-tech

I haven't tried posting there, but I did post to trousers-users on the 25th of September, subject 'TPM support in my application'. That doesn't appear in the archives either (but if you find it, don't bother; I have patches for most of it now).

Would you like to own the openssl-tpm-engine package? I could only be a package-monkey for it, not a real maintainer.
Comment 5 David Woodhouse 2008-10-03 06:32:34 EDT
Fixed tspi library handling so it doesn't depend on trousers-devel, but only on trousers, and that dependency is picked up properly by RPM.

Spec URL: http://david.woodhou.se/openssl-tpm-engine.spec
SRPM URL: http://david.woodhou.se/openssl-tpm-engine-0.4.1-4.fc9.src.rpm
Comment 6 Jason Tibbitts 2009-07-14 18:45:51 EDT
Another old one; unfortunately it fails to build:

+ aclocal
+ automake --add-missing -c --foreign
Makefile.am:5: Libtool library used but `LIBTOOL' is undefined
Makefile.am:5:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
Makefile.am:5:   to `configure.in' and run `aclocal' and `autoconf' again.
Makefile.am:5:   If `AC_PROG_LIBTOOL' is in `configure.in', make sure
Makefile.am:5:   its definition is in aclocal's search path.
error: Bad exit status from /var/tmp/rpm-tmp.9uMxE4 (%build)
Comment 7 Thomas Spura 2009-10-23 16:55:51 EDT
Here is a different build error:

./libtool: line 775: X--tag=CC: command not found
./libtool: line 808: libtool: ignoring unknown tag : command not found
./libtool: line 775: X--mode=compile: command not found
./libtool: line 925: *** Warning: inferring the mode of operation is deprecated.: command not found
./libtool: line 926: *** Future versions of Libtool will require --mode=MODE be specified.: command not found

and many more...

David, are you still working on this?
Comment 8 David Woodhouse 2009-10-23 18:56:11 EDT
Ew, libtool. I think I'll rewrite it to use proper Makefiles instead. Yes, I'd still like this to go in.
Comment 9 Jason Tibbitts 2009-11-07 20:27:24 EST
Indicating that this doesn't build; please clear the whiteboard when that's been fixed.
Comment 10 Jason Tibbitts 2010-01-25 18:15:01 EST
This is still marked as not building.  Can we fix that up or close this ticket out?
Comment 11 David Woodhouse 2010-01-26 00:28:53 EST
The autohell problems are the least of my worries right now -- when I make it build against OpenSSL 1.0.0 it doesn't _work_ either.

http://www.mail-archive.com/trousers-tech@lists.sourceforge.net/msg00024.html

I'm working on it, but slowly.
Comment 12 Jason Tibbitts 2010-11-02 17:21:10 EDT
And, after a few days short of a year, still marked as not building.  I saw that something happened back in April but I don't know if there's still any desire to get this package in.

Note You need to log in before you can comment on or make changes to this bug.