Bug 464758 - PHPUnit is lacking dependency on php-xml
PHPUnit is lacking dependency on php-xml
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: php-pear-PHPUnit (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Stone
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 06:40 EDT by Daniel Rindt
Modified: 2008-10-15 22:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 22:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Rindt 2008-09-30 06:40:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):
php-pear-PHPUnit-3.1.9-1.fc8

How reproducible:
always

Steps to Reproduce:
1. phpunit --report ../Reports --verbose MyDirectoryIteratorTest.php
2.
3.
  
Actual results:
PHPUnit execution ends with the message:
PHP Fatal error:  Class 'DOMDocument' not found in /usr/share/pear/PHPUnit/Util/Log/XML.php on line 136

Expected results:


Additional info:
the package php-pear-PHPUnit should have in their dependency list 'php-xml' to work properly. the problem is solved after installing php-xml.
Comment 1 Fedora Update System 2008-10-09 12:11:57 EDT
php-pecl-xdebug-2.0.3-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.0.3-2.fc9
Comment 2 Fedora Update System 2008-10-09 12:12:36 EDT
php-pecl-xdebug-2.0.3-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.0.3-2.fc8
Comment 3 Christopher Stone 2008-10-09 12:13:52 EDT
oops ignore those comments, got wrong bug #...fixing...
Comment 4 Fedora Update System 2008-10-09 12:32:40 EDT
php-pear-PHPUnit-3.1.9-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/php-pear-PHPUnit-3.1.9-2.fc8
Comment 5 Fedora Update System 2008-10-09 12:33:18 EDT
php-pear-PHPUnit-3.2.21-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/php-pear-PHPUnit-3.2.21-1.fc9
Comment 6 Fedora Update System 2008-10-09 15:10:43 EDT
php-pecl-xdebug-2.0.3-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.0.3-4.fc9
Comment 7 Fedora Update System 2008-10-09 15:11:30 EDT
php-pecl-xdebug-2.0.3-4.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.0.3-4.fc8
Comment 8 Fedora Update System 2008-10-15 22:01:25 EDT
php-pear-PHPUnit-3.1.9-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-10-15 22:04:46 EDT
php-pecl-xdebug-2.0.3-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-10-15 22:08:55 EDT
php-pecl-xdebug-2.0.3-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-10-15 22:11:07 EDT
php-pear-PHPUnit-3.2.21-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.