Bug 464771 - NameError: global name 'log' is not defined
NameError: global name 'log' is not defined
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 09:01 EDT by Alexander Todorov
Modified: 2009-01-20 16:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:36:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (86.96 KB, text/plain)
2008-09-30 09:01 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-09-30 09:01:19 EDT
Created attachment 318068 [details]
anacdump.txt

Description of problem:
traceback in anaconda GUI. see steps to reproduce

Version-Release number of selected component (if applicable):
anaconda-11.1.2.132-1

How reproducible:
Always

Steps to Reproduce:
1. boot the installer (vnc mode)
2. select default partitioning & encryption (or any other partitioning scheme as long as encryption is enabled)
3. a pass phrase dialog appears, click Cancel
4. another dialog appears asking you to go back or continue without encryption (since you canceled the pass phrase dialog). Click continue.
  
Actual results:
Traceback

Expected results:
Anaconda proceeds without encryption enabled but preserving the current partitioning scheme.

Additional info:
Traceback (most recent call first):
  File "/usr/lib/anaconda/partitioning.py", line 114, in partitioningComplete
    log.info("user elected to not encrypt any devices.")
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1151, in nextClicked
    self.anaconda.dispatch.gotoNext()
NameError: global name 'log' is not defined
Comment 1 Chris Lumens 2008-09-30 10:07:41 EDT
This will be fixed in anaconda-11.1.2.133-1.
Comment 2 RHEL Product and Program Management 2008-09-30 10:35:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2009-01-20 16:36:39 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html

Note You need to log in before you can comment on or make changes to this bug.