Bug 464779 - Evolution plugin broken on evolution 2.23.5 and higher
Evolution plugin broken on evolution 2.23.5 and higher
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 09:51 EDT by Erik van Pienbroek
Modified: 2008-10-01 10:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 10:57:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (807 bytes, patch)
2008-09-30 09:51 EDT, Erik van Pienbroek
no flags Details | Diff

  None (edit)
Description Erik van Pienbroek 2008-09-30 09:51:30 EDT
Created attachment 318076 [details]
Proposed patch

Hi,

In august 2008 I reported #458587 (mail-notification needs rebuild for evolution 2.24) which was fixed. However, it introduced a new regression. Every time evolution starts, evolution immediately crashes. When evolution is started without plugins (evolution --disable-eplugin) everything is okay (but the mail notification plugin doesn't load of course).

After searching upstream's bugtracker I stumbled upon https://bugs.launchpad.net/mail-notification/+bug/251031 which looks exactly like the crash I was having. The cause of the problem wasn't known yet so I decided to look into it myself. I've found out that the cause of the regression is a change in the behaviour in one of the functions in evolution-data-server 2.23.5. I've proposed a patch to fix this behaviour at august 12 2008. However, upstream hasn't responded to it yet and it doesn't look like a new release of mail-notification is coming any day now..

So that's why I want to ask you if you want to incorporate my patch in the Fedora package of mail-notification. The patch is compatible with both old and new (2.23.5+) versions of evolution.
Comment 1 Dmitry Butskoy 2008-10-01 10:57:21 EDT
Re-built with your patch, see
http://kojipkgs.fedoraproject.org/packages/mail-notification/5.4/3.fc10/

Thanks.

Note You need to log in before you can comment on or make changes to this bug.