This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 464816 - CPU time limit reached
CPU time limit reached
Status: CLOSED DUPLICATE of bug 462200
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 13:09 EDT by Martin Jürgens
Modified: 2008-10-19 16:41 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-19 16:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pulseaudio log (9.59 KB, text/plain)
2008-10-01 04:52 EDT, Martin Jürgens
no flags Details
pulseaudio log (7.37 KB, application/octet-stream)
2008-10-01 05:54 EDT, Luca Foppiano
no flags Details
pulseaudio log (14.44 KB, text/plain)
2008-10-08 16:38 EDT, Michael Cronenworth
no flags Details
pulseaudio log (38.63 KB, text/plain)
2008-10-11 13:15 EDT, Dario Castellarin
no flags Details

  None (edit)
Description Martin Jürgens 2008-09-30 13:09:36 EDT
pulseaudio always crashes for me after some time: this is the cli output:

$ pulseaudio 
W: pid.c: Stale PID file, overwriting.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Die Operation ist nicht erlaubt
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Die Operation ist nicht erlaubt
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.


pulseaudio-0.9.10-1.fc9.i386
Comment 1 Lennart Poettering 2008-09-30 22:03:50 EDT
Please run pulseaudio -vvv.

What kind of audio driver is this?
Comment 2 Martin Jürgens 2008-10-01 04:52:49 EDT
Created attachment 318173 [details]
pulseaudio log

information about audio driver: http://www.alsa-project.org/db/?f=ddbf3008b84ce8c42ab6b734c13ac7e9558c103d


log attached
Comment 3 Luca Foppiano 2008-10-01 05:54:08 EDT
Created attachment 318175 [details]
pulseaudio log
Comment 4 Luca Foppiano 2008-10-01 06:01:11 EDT
I have the same problem...linked above. 

My audiocard:

* lspci

[lfoppiano@sboing ~]$ /sbin/lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)


* lsmod

[lfoppiano@sboing ~]$ /sbin/lsmod | grep snd
snd_hda_intel         435244  1 
snd_seq_dummy          11396  0 
snd_seq_oss            37824  0 
snd_seq_midi_event     14976  1 snd_seq_oss
snd_seq                57872  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15124  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            45568  0 
snd_mixer_oss          22912  2 snd_pcm_oss
snd_pcm                79240  2 snd_hda_intel,snd_pcm_oss
snd_timer              28688  2 snd_seq,snd_pcm
snd_page_alloc         16528  2 snd_hda_intel,snd_pcm
snd_hwdep              16136  1 snd_hda_intel
snd                    64120  9 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              14864  2 snd


* aplay 

[lfoppiano@sboing ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Comment 5 Michael Cronenworth 2008-10-08 00:18:31 EDT
I also have the same problem. This started a month or so ago. I thought an update would come out and fix this, but nothing has yet.

Pulseaudio will work fine 99% of the time. However, when the computer is under heavy usage pulseaudio will choke and quit with the lines:
Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.

Xeon E3110 3ghz (45nm dual-core)
card 1: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]

This can also happen if there's moderate load, say playing back H.264 1080P video in totem, but I can definitely reproduce it every time under heavy load. Heavy load being a 3D game such as a game through Wine.

I've never seen Pulseaudio die under any other conditions. If the CPU load is 25% or lower it never dies. Executing `pulseaudio -D --log-target=syslog` gets things going again of course.
Comment 6 Luca Foppiano 2008-10-08 12:09:41 EDT
(In reply to comment #5)

> Pulseaudio will work fine 99% of the time. However, when the computer is under
> heavy usage pulseaudio will choke and quit with the lines:

[...]

> Xeon E3110 3ghz (45nm dual-core)
> card 1: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
> 
> This can also happen if there's moderate load, say playing back H.264 1080P
> video in totem, but I can definitely reproduce it every time under heavy load.
> Heavy load being a 3D game such as a game through Wine.
> 
> I've never seen Pulseaudio die under any other conditions. If the CPU load is
> 25% or lower it never dies. Executing `pulseaudio -D --log-target=syslog` gets
> things going again of course.

you've got the point, IMHO the problem is when CPU is under stress


Luca
Comment 7 Michael Cronenworth 2008-10-08 16:38:44 EDT
Created attachment 319798 [details]
pulseaudio log

I've attached the log output of `pulseaudio -vvv` from my system. After playing three hi-definition videos pulseaudio died. It was about 20 minutes into the third video. Each video are about 45 minutes long. As you can see from the log, there is nothing visually striking about the death of pulse. CPU usage was averaging 25%, so instead of dying instantly under higher stress, it took multiple videos at a lower stress level to kill.
Comment 8 Dario Castellarin 2008-10-11 13:14:40 EDT
I'm seeing the same problem here on an ICH8M controller (HDA Intel driver), even though I didn't see it connected to the processor load, here it dies even if the only running thing is Rhythmbox. Also, it does it toally randomly, it can die after a minute or after hours... I'm attaching the output of pulseaudio -vvv.
Ah yes, system is F9 x86_64.
Comment 9 Dario Castellarin 2008-10-11 13:15:30 EDT
Created attachment 320099 [details]
pulseaudio log
Comment 10 Timon 2008-10-15 09:00:07 EDT
I have same bug. it randomly happens when I listen music.
pulseaudio eats one core of my CPU and stop playing music and after some time hangs with 
Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.
if I run pulseaudio with --no-cpu-limit parameter it only stops for minute

strace shows me at this moment 

[timon@localhost ~]$ sudo strace -p 4115
Process 4115 attached - interrupt to quit
futex(0x8cb65b8, FUTEX_WAIT_PRIVATE, 0, NULL

if you give me some info how to debug this under gdb, I think I can do this :)

[timon@localhost ~]$ rpm -q pulseaudio
pulseaudio-0.9.10-2.fc9.i386

this bug similar to http://www.pulseaudio.org/ticket/245
Comment 11 Peter Dawes 2008-10-15 09:17:38 EDT
I was experiencing this issue as well, with an Intel HD Audio chipset (Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01) to be precise).  The solution in comment #10 (and 11) of bug 462200 appears to have solved it for me.
Comment 12 Timon 2008-10-18 07:14:12 EDT
I confirm comment #11. Using snd-hda-intel.ko from kernel 2.6.27 solves this problem. So seems that this is kernel bug and not a pulseaudio bug.
Comment 13 Eric Hopper 2008-10-18 13:29:52 EDT
This is a dupe of bug 462200
Comment 14 Lennart Poettering 2008-10-19 16:37:29 EDT
If you stress the CPU it might happen that PA gets scheduled less often then it should and it notices a drop-out, in which case it will ask to be woken up earlier next time to play sure. However that increases the CPU load and might then end up causing the CPU load limiter to become active.
Comment 15 Lennart Poettering 2008-10-19 16:41:04 EDT
Hmm, Eric is right, this actually looks a lot like a dupe of bug 462200

*** This bug has been marked as a duplicate of bug 462200 ***

Note You need to log in before you can comment on or make changes to this bug.