This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 464820 - Netbeans displays non-free EULA on startup
Netbeans displays non-free EULA on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netbeans (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Victor G. Vasilyev
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-30 13:35 EDT by Mark Wielaard
Modified: 2013-01-10 01:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 20:11:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NetBeans EULA text shown at startup (75.33 KB, text/plain)
2008-09-30 13:42 EDT, Mark Wielaard
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
NetBeans Project 148781 None None None Never

  None (edit)
Description Mark Wielaard 2008-09-30 13:35:32 EDT
Description of problem:

When starting NetBeans for the first time it puts up a modal dialog saying: "If you accept all terms of the agreement, click I Accept to start NetBeans IDE. You must accept the agreement to start NetBeans IDE."

The terms contain several non-free terms like "You may only use the Software in binary form and only in conjunction with NetBeans.", ""You may not publish or provide the results of any benchmark or comparison tests run on Software to any third party without the prior written consent of Sun.", ""Software may contain Java technology. You may not create additional classes to, or modifications of, the Java technology".

It also contains the text of the GPL which actually says: "Activities other than copying, distribution and modification are not covered by this License; they are outside its scope.The act of running the Program is not restricted"

So, which is it? Do I need to accept these terms or not? And the additional licenses mentioned after the GPL seem very proprietary and non-free.

Version-Release number of selected component (if applicable):

netbeans.noarch 0:6.1-4.fc10

How reproducible:

Always

Steps to Reproduce:
1. yum install netbeans
2. netbeans
  
Actual results:

Obnoxious modal dialog which forces me to accept non-free software terms.

Expected results:

Happily using a free software java IDE under the GPL.

Additional info:

Full EULA attached.
Comment 1 Mark Wielaard 2008-09-30 13:42:00 EDT
Created attachment 318099 [details]
NetBeans EULA text shown at startup

Full EULA text that netbeans wants the end user to accept before running.
Comment 2 Tom "spot" Callaway 2008-09-30 13:43:51 EDT
Victor, this is pretty bad. We need to get this resolved, or I'll be forced to remove this code from Fedora.
Comment 3 Victor G. Vasilyev 2008-09-30 14:11:39 EDT
Tom,

Sorry, it is my fault. The text shown at startup is not applicable for a version of the NetBeans that is provided for Fedora. Of course, this bug will be fixed immediately.
Comment 4 Alexei Mokeev 2008-10-01 01:59:15 EDT
Netbeans 6.1 in Fedora is fully covered by GPLv2 with Classpath Exception")
or the Common Development and Distribution License ("CDDL") if user wish.

The 3 more licenses that are included into the text (for Jgo, Tom Sowyer and Sun WTK) covers use of components, that are not included into Fedora packages.

And, of course, this problem inadequate license popup will be solved.
Comment 5 Victor G. Vasilyev 2008-10-01 12:46:28 EDT
The release 6 has been committed into CVS repo.
Successful koji build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=854155
 
Changes:
- Showing an incorrect EULA at startup is disabled

Hence, an inadequate license won't be shown anymore at startup and a user will never be asked about accepting a license agreement for the configuration of the NetBeans that is intended for Fedora.  So, NetBeans is still under GPLv2 with exceptions or CDDL by default.

Note You need to log in before you can comment on or make changes to this bug.