Bug 464826 - Upstream production linuxwacom is 0.8.0
Upstream production linuxwacom is 0.8.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On: 109750
Blocks: 466300
  Show dependency treegraph
 
Reported: 2008-09-30 14:14 EDT by Luya Tshimbalanga
Modified: 2009-07-16 04:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 04:08:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luya Tshimbalanga 2008-09-30 14:14:22 EDT
Description of problem:
Fedora version of linuxwacom currently does not support xorg 7.3. Upstream version has updated to 0.8.x for production while development version is 0.8.1-4

Version-Release number of selected component (if applicable):
0.7.9.8-7

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Current version will have tablet cursor freeze since there is no xorg.conf. More details are available on #109750.
Comment 1 Aristeu Rozanski 2008-10-02 17:04:12 EDT
no difference here. the driver doesn't supports to be loaded without
configuration (it requires at least "Type") and there's no way to simply
change the hal rules to create three different X extended devices from the
same evdev file. Changes are required on linuxwacom itself and 0.8.0 doesn't
have this fixed or 0.8.1. I'm working on a solution, but having someone who
knows xorg input drivers would help me a lot.
Comment 2 Luya Tshimbalanga 2008-10-02 21:40:52 EDT
Thank you for the effort. Unfortunately, my skill is very limited when it comes to know xorg input drivers for tablet. I wonder if there is anyone skilled on that part.
Comment 3 Bug Zapper 2008-11-25 22:17:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Luya Tshimbalanga 2009-01-02 21:20:09 EST
0.8.0.3 works without the use of xorg.conf on Fedora 10. Only issue is the eraser from the stylus is disabled from several applications like Gimp despite the setting. Should that issue be fixed, I think the bug will be solved.
Comment 5 Luya Tshimbalanga 2009-06-12 15:17:37 EDT
It appears this bug has been resolved on Fedora 11. I am not sure if Cambridge version got sorted. Should the problem be solved in that case, it would be nice to close this bug.

Note You need to log in before you can comment on or make changes to this bug.