Bug 464869 - Fedora Core Beta DVDs crash on Lenovo X301 ThinkPad when X server runs.
Fedora Core Beta DVDs crash on Lenovo X301 ThinkPad when X server runs.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 18:09 EDT by Olin Shivers
Modified: 2009-02-10 05:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 17:14:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olin Shivers 2008-09-30 18:09:15 EDT
Description of problem:

The Fedora Core 10 beta install DVD and the live DVD crash on my Lenovo X301
ThinkPad. Everything goes fine until the X server tries to come up, then
the system either locks up or reboots.

Steps to Reproduce:
1. Insert DVD into computer
2. Press power button
3. For install DVD, move through selections; for live DVD, sit & watch.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2008-10-26 17:27:14 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and cp /tmp/* to some other place -- USB stick, some other computer via network, some on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Matěj Cepl 2008-11-24 06:39:09 EST
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 3 Bug Zapper 2008-11-25 22:18:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Joel Uckelman 2008-12-01 07:49:48 EST
Hi, I have an X30 and have the same problem.

I tried to upgrade to Fedora 10 from Fedora 9 using a DVD in an external USB drive, I tried to upgrade from an external USB hard disk, I tried to upgrade from the internal hard disk, I tried to upgrade using the preinstall package. In all of these cases, as soon as the installer tried to start X, a portion of the GUI was rendered (background, but no foreground) and I got an almost total lock-up (keyboard dead, but could still move the mouse pointer).

At this point, I suspected that the problem was with the installer, not X, and so I did the upgrade using yum. However, it's clear now that the problem is with X, not the installer, since (1) if I boot to runlevel 3, I can verify that the upgrade was successful, and everything except X seems to be running fine, and (2) if I try to start X, even with an xorg.conf using the VESA driver, I get total screen corruption.

As this renders my wife's laptop totally unusable, I'll happily and rapidly provide whatever information you need for resolving the problem.
Comment 5 Joel Uckelman 2008-12-01 15:01:15 EST
I found that adding the line

Option "NoAccel" "yes"

to my xorg.conf made X usable again. However, it's kind of suboptimal turning off hardware acceleration.
Comment 6 Joel Uckelman 2009-01-23 08:40:10 EST
I believe this bug is caused by the same problem as Bug 469292.
Comment 7 François Cami 2009-02-09 17:14:07 EST
The information we've requested above is required in order
to review this problem report further and diagnose or fix the
issue if it is still present.  Since it has been thirty days or
more since we first requested additional information, we're assuming
the problem is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED: INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested,
please feel free to reopen the bug report.

Thank you in advance.
Comment 8 Joel Uckelman 2009-02-10 05:50:52 EST
(In reply to comment #7)
> The information we've requested above is required in order
> to review this problem report further and diagnose or fix the
> issue if it is still present.

It's impossible to provide the requested information, because this problem locks up the keyboard. There's no way to switch to a console once the problem occurs.
Is there any other information I can provide for you?

Anyway, I believe this bug is the same as Bug 474118.

Note You need to log in before you can comment on or make changes to this bug.