Bug 464884 - system-config-network - NetworkManager - manual restart off internet
system-config-network - NetworkManager - manual restart off internet
Status: CLOSED DUPLICATE of bug 459017
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 20:47 EDT by Flóki Pálsson
Modified: 2008-10-02 11:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 11:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/networking/devices/ifcfg-eth0 and 1 before and after (835 bytes, text/plain)
2008-10-01 17:06 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2008-09-30 20:47:29 EDT
Description of problem:
After adding a host in system-config-network and deactivate eth1 and activate eth1 again, then  NetworkManager shows no connection.
After rebooting then network connection has to be activated manually with system-config-network.  
NetworkManager never shows connection. 
Firefox, Evolution, Epiphany are in offline mode after reboot,
even thought they are stared after network 
( internet connection ( wiered )) has been activated  . 


Version-Release number of selected component (if applicable):
system-config-network-1.5.10-1.fc9.noarch
NetworkManager-0.7.0-0.11.svn4022.2.fc10.x86_64


How reproducible:


Steps to Reproduce:
1.
Add host in system-config-network.
2.
deactivate eth1 and activate eth1.
3.
  
Actual results:
NetworkManager shows no connection.
After reboot.  No internet connection.


Expected results:
NetworkManager ( applet in upper right corner )to show connection when there is internet connection.  

Additional info:
I have repeated this problem in FC10 many times.
Comment 1 Jiri Moskovcak 2008-10-01 05:59:55 EDT
Hi,
can you please check /etc/sysconfig/networking/devices/ifcfg-eth0 for line NM_CONTROLLED. I guess it's the same problem as in rhbz#459017 because if there's no line NM_CONTROLLED then s-c-n take it as NO and NetworkManager as yes. So if you deactivate and activate device via s-c-n and let s-c-n save the new configuration it writes NM_CONTROLLED=no to ifcfg-* file and that's why NM doesn't handle the device... You can to edit your eth1 config with s-c-n and check the "Controlled by NetworkManager" option.
Comment 2 Flóki Pálsson 2008-10-01 17:06:12 EDT
Created attachment 319165 [details]
/etc/sysconfig/networking/devices/ifcfg-eth0 and 1 before and after 

Changes with  system-config-network.   
Changes on device eth1
 x Controlled by NetworkManager
 x Activate device when computer starts

Atter that inernet is connected after reboot and firefox and  .. are in online mode when started.
Comment 3 Jiri Moskovcak 2008-10-02 11:05:29 EDT

*** This bug has been marked as a duplicate of bug 459017 ***

Note You need to log in before you can comment on or make changes to this bug.