Bug 464900 - Boot sequence fails with encrypted /home on native partition
Boot sequence fails with encrypted /home on native partition
Status: CLOSED DUPLICATE of bug 464787
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 05:06 EDT by Alexander Todorov
Modified: 2008-10-01 10:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 10:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-01 05:06:13 EDT
Description of problem:
The boot sequence fails when /home is on separate physical partition and is encrypted.

Version-Release number of selected component (if applicable):
initscripts-8.45.20-1

How reproducible:
Always

Steps to Reproduce:
1. Install the system. Disk layout is:
/dev/sda1 vfat /boot/efi  (on ia64 or /boot otherwise)
/dev/sda2 ext3 /          not ecnrypted
/dev/sdb1 ext3 /home      encrypted

2. Reboot after install

Actual results:
System failed to boot

Expected results:
System boots and asks the user for a pass phrase late in the init process

Additional info:
The console message is:

Loading default keymap (us): [  OK  ]
Setting hostname localhost.localdomain:  [  OK  ]
Starting disk encryption:
Command failed: Error opening device: No such file or directory
[FAILED]
No devices found
Setting up Logical Volume Management: [  OK  ]
Checking filesystems
Checking all file systems.
[/sbin/fsck.ext3 (1) -- /] fsck.ext3 -a /dev/sda2 
/: clean, 17798/35848192 files, 1353630/35818076 blocks
[/sbin/fsck.ext3 (1) -- /home] fsck.ext3 -a LABEL=/home 
fsck.ext3: Unable to resolve 'LABEL=/home'
[FAILED]

*** An error occurred during the file system check.
*** Dropping you to a shell; the system will reboot
*** when you leave the shell.
*** Warning -- SELinux is active
*** Disabling security enforcement for system recovery.
*** Run 'setenforce 1' to reenable.
Give root password for maintenance
(or type Control-D to continue):
Comment 1 Alexander Todorov 2008-10-01 05:10:59 EDT
More info after typin gin the root password:

(Repair filesystem) 1 # cat  /etc/crypttab 
luks-fd15a4e9-8921-4683-937c-7f6d95f6a352 UUID=fd15a4e9-8921-4683-937c-7f6d95f6a352 none

(Repair filesystem) 2 # cat /etc/fstab 
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/home             /home                   ext3    defaults        1 2
/dev/sda1               /boot/efi               vfat    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0

(Repair filesystem) 7 # dumpe2fs  /dev/sdb1
dumpe2fs 1.39 (29-May-2006)
dumpe2fs: Bad magic number in super-block while trying to open /dev/sdb1
Couldn't find valid filesystem superblock.
Comment 2 Alexander Todorov 2008-10-01 10:09:05 EDT

*** This bug has been marked as a duplicate of bug 464787 ***

Note You need to log in before you can comment on or make changes to this bug.