Bug 464910 - PK "completed" dialog is premature
PK "completed" dialog is premature
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 06:52 EDT by Paul W. Frields
Modified: 2008-10-27 09:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:24:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2008-10-01 06:52:42 EDT
PackageKit-0.2.5-1.fc9.x86_64

Use case:
Updates are avaialble, and my gpk-update-icon appears as usual.  I select it and choose "Show Updates" because I like to see what's going to be installed.  I read the details and then choose "Install updates."

"Great," I think, "now I can do away with this dialog and get on with my work while PK does its thing in the background."  I click the Close button, but suddenly I get a new dialog saying all updates are completed!  I know for a fact that's not true, because the gpk-update-icon still reports that it's resolving dependencies.

Problem:
PK should not display the "completed" dialog unless the progress dialog is visible (i.e. not swallowed/hidden), *and* it's actually done.  The current results are quite confusing, especially, I would imagine, to a new user and lead to the erroneous conclusion that there's something wrong with PK beyond just some UI logic.
Comment 1 Richard Hughes 2008-10-09 12:31:09 EDT
I think this is fixed in rawhide, right?

Note You need to log in before you can comment on or make changes to this bug.