Bug 464912 - hddtemp still spins up the disk
hddtemp still spins up the disk
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hddtemp (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 07:50 EDT by Sascha Zorn
Modified: 2008-10-15 22:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 22:03:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 160621 None None None Never

  None (edit)
Description Sascha Zorn 2008-10-01 07:50:04 EDT
Description of problem:
Even if the -w (wakeup) flag is NOT provided, hddtemp spins up the disk. 

I found that this bug is already discussed in launchpad #160621
and regarded as solved for version 0.3-beta15-43.

I've checked the rawhide repo for a version that contains this fix, but the version there is still buggy.

Version-Release number of selected component (if applicable):
0.3-0.15.beta15.fc9

How reproducible:
#hdparm -C /dev/sda
/dev/sda:
 drive state is:  standby

# hddtemp /dev/sda
/dev/sda: FUJITSU MHV2080BH: 39°C

# hdparm -C /dev/sda
/dev/sda:
 drive state is:  active/idle
  
Actual results:
drive spins up

Expected results:
check does not take place if -w is not provided, maybe check if a disk supports a readout without waking it up

Additional info:
Comment 1 Ville Skyttä 2008-10-01 14:02:09 EDT
Thanks for the report.  Confirmed on two F-9 boxes, one with a PATA (libata) drive and another with a SATA drive, applying the fix from Debian fixes both.
Comment 2 Fedora Update System 2008-10-01 14:14:59 EDT
hddtemp-0.3-0.16.beta15.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/hddtemp-0.3-0.16.beta15.fc9
Comment 3 Fedora Update System 2008-10-03 18:30:15 EDT
hddtemp-0.3-0.16.beta15.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hddtemp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8562
Comment 4 Sascha Zorn 2008-10-09 14:14:19 EDT
I've tried hddtemp-0.3-0.16.beta15.fc9 and can confirm that hddtemp now behaves correctly!
Comment 5 Ville Skyttä 2008-10-09 15:45:28 EDT
Thanks for the confirmation.  If you don't mind, providing one more "works for me" comment in Bodhi for the update (see comment 3 for the URL) would cause it to be pushed to stable updates...
Comment 6 Fedora Update System 2008-10-15 22:03:32 EDT
hddtemp-0.3-0.16.beta15.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.