Bug 464915 - lightning extension mangles the calendar display
lightning extension mangles the calendar display
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sunbird (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 08:09 EDT by Julian Sikorski
Modified: 2009-05-08 03:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 03:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing the erroneous behavior (94.30 KB, image/png)
2008-10-01 08:09 EDT, Julian Sikorski
no flags Details

  None (edit)
Description Julian Sikorski 2008-10-01 08:09:02 EDT
Created attachment 318184 [details]
screenshot showing the erroneous behavior

Description of problem:
Upon update to lightning-0.9-2.fc9, the calendar part of thunderbird is mangled badly. The events have proper dates set, but the way they are shown in the calendar is wrong - one day off and taking up the whole day. The same calendar works fine in lightning 0.8, as well as in lightning 0.9 in Windows (I symlinked the latter and the problem persists).

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.16-1.fc9.x86_64
thunderbird-lightning-0.9-2.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. create a calendar in lightning-0.8
2. update to thunderbird-lightning-0.9-2.fc9
3. restart thunderbird
  
Actual results:
calendar is mangled

Expected results:
entries are shown with proper time and length

Additional info:
Please have a look at the screenshot and see how the events in the top center are inconsistent with those at the bottom center.
Comment 1 Julian Sikorski 2008-10-01 08:14:52 EDT
Also, please note that installing the xpi from mozilla.org - http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/0.9/contrib/linux-x86_64/ gives proper results.
Comment 2 Lubomir Rintel 2008-10-01 11:07:57 EDT
Thanks for the report. I suspect this is due to the way I use the external libical. Will have a look.
Comment 3 Lubomir Rintel 2008-10-27 05:47:34 EDT
Should be fixed in thunderbird-lightning-0.9-3.fc9.
Please confirm.
Comment 4 Julian Sikorski 2008-10-27 07:54:32 EDT
I'll test it as soon as it is available in koji.
Comment 5 Lubomir Rintel 2008-10-27 10:22:23 EDT
I think actually already is, for some time. I just forgot to close the report.
Comment 6 Julian Sikorski 2008-10-27 12:10:10 EDT
There are 2.fc9.1 (built with internal libical) and 3.fc10 (built with system libical, but claims to be fixed). There is no 3.fc9.
Comment 7 Lubomir Rintel 2009-05-08 03:19:20 EDT
Umm, sorry, I'm not going to release an update to Fedora 9. Use Fedora 10 please.

Note You need to log in before you can comment on or make changes to this bug.