Bug 464921 - xorg stuck at 640x480 on ATi Xpress 200M
xorg stuck at 640x480 on ATi Xpress 200M
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 09:33 EDT by Jeff Layton
Modified: 2014-06-18 03:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 13:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg after boot with display stuck at 640x480 (28.86 KB, text/plain)
2008-10-01 09:33 EDT, Jeff Layton
no flags Details
xorg.conf after upgrade (1.18 KB, text/plain)
2008-10-01 09:33 EDT, Jeff Layton
no flags Details
Xorg.log (29.87 KB, text/plain)
2008-10-01 09:34 EDT, Jeff Layton
no flags Details
Screenshot showing screen distortion on right side (240.25 KB, application/octet-stream)
2008-10-04 22:55 EDT, Gerald Cox
no flags Details
gbcox - Xorg Log File (48.77 KB, application/octet-stream)
2008-10-04 22:57 EDT, Gerald Cox
no flags Details
gbcox - Xorg Conf created with system-config-display (804 bytes, application/octet-stream)
2008-10-04 22:58 EDT, Gerald Cox
no flags Details

  None (edit)
Description Jeff Layton 2008-10-01 09:33:04 EDT
Created attachment 318192 [details]
dmesg after boot with display stuck at 640x480

I just updated my laptop to F10Beta. When it comes up, X starts with the display set to 640x480 and won't allow it to be changed to any other resolution.

Booting with "nomodeset" seems to work around the problem. With that, X starts up at the laptop's native 1280x800 resolution.

As a side note compiz no longer seems to work (X crashes back to the login screen when I try to enable it), but that seems likely to be a separate problem.
Comment 1 Jeff Layton 2008-10-01 09:33:43 EDT
Created attachment 318193 [details]
xorg.conf after upgrade
Comment 2 Jeff Layton 2008-10-01 09:34:23 EDT
Created attachment 318194 [details]
Xorg.log
Comment 3 Jeff Layton 2008-10-01 09:37:21 EDT
I should also mention that the laptop was at F9 before the upgrade. Let me know if you need me to collect more info or test patches, etc...
Comment 4 Gerald Cox 2008-10-04 22:54:12 EDT
I had the same problem, when using nomodeset also noticed resolution was 1280x800 - however the screen appears to be "cutoff or distorted" on the right side, as if this wasn't a widescreen display.  I've attached a screenshot which shows the issue, in addition to my log file and xorg.conf (created with system-config-display).  I did a new install, not an upgrade.
Comment 5 Gerald Cox 2008-10-04 22:55:46 EDT
Created attachment 319483 [details]
Screenshot showing screen distortion on right side
Comment 6 Gerald Cox 2008-10-04 22:57:28 EDT
Created attachment 319484 [details]
gbcox - Xorg Log File
Comment 7 Gerald Cox 2008-10-04 22:58:58 EDT
Created attachment 319485 [details]
gbcox - Xorg Conf created with system-config-display
Comment 8 Jeff Layton 2008-10-23 13:24:26 EDT
This problem seems to be resolved for me in more recent kernels. With 2.6.27.3-30.rc1.fc10, I can now boot into X at the proper resolution without using "nomodeset".

I'm having a different problem now with -34.rc1 where X isn't working, but that's a different problem. I'll go ahead and close this. Please reopen if you're still having the problem.

Note You need to log in before you can comment on or make changes to this bug.