Bug 464930 - Multilib conflict - /usr/share/doc/perl-5.10.0/Changes*.gz conflicts
Summary: Multilib conflict - /usr/share/doc/perl-5.10.0/Changes*.gz conflicts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Stepan Kasal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-01 14:29 UTC by Adam Tkac
Modified: 2013-04-30 23:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 08:52:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Tkac 2008-10-01 14:29:26 UTC
Description of problem:
when I try update multilib machine (x86_64, ppc, ppc64) with multilib perl installed update fails

Version-Release number of selected component (if applicable):
perl-5.10.0-44.fc10

How reproducible:
always

Steps to Reproduce:
1. on x86_64 try install perl.x86_64 and perl.i386
  
Actual results:
Transaction Check Error:
  file /usr/share/doc/perl-5.10.0/Changes.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.000.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.001.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.002.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.003.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.004.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.005.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.6.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64
  file /usr/share/doc/perl-5.10.0/Changes5.8.gz from install of perl-4:5.10.0-44.fc10.i386 conflicts with file from package perl-4:5.10.0-44.fc10.x86_64

Expected results:
successfull installation

Comment 1 Tom "spot" Callaway 2008-10-01 15:06:48 UTC
Looking at this, it is due to either some pecularity of gzip, or the differing timestamps on the created gzip files. The files inside the gzip match sha1sums, but the gz files themselves do not, which is why rpm is throwing this error.

The obvious fix would be to not gzip these files, but it would also make the perl package notably larger (2.4M gzipped, 11M uncompressed).

I think we can fix this by doing:

touch -r Artistic Changes*.gz

Thus, giving them all the same timestamp. I'm testing this out now.

Comment 2 Tom "spot" Callaway 2008-10-01 15:40:15 UTC
(In reply to comment #1)

> Thus, giving them all the same timestamp. I'm testing this out now.

... and I was wrong. This doesn't do the trick, but kasal has a better plan. :)

Comment 3 Stepan Kasal 2008-10-02 08:52:31 UTC
Seems my fix works! ;-)
Fixed in perl-5.10.0-46.fc10


Note You need to log in before you can comment on or make changes to this bug.