This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 465017 - FTBFS lout-3.36-2.fc9
FTBFS lout-3.36-2.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lout (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: F10FTBFS
  Show dependency treegraph
 
Reported: 2008-10-01 11:53 EDT by FTBFS
Modified: 2008-10-02 13:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 13:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (646.78 KB, text/plain)
2008-10-01 11:53 EDT, FTBFS
no flags Details
build.log (61.46 KB, text/plain)
2008-10-01 11:53 EDT, FTBFS
no flags Details
mock.log (917 bytes, text/plain)
2008-10-01 11:53 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-10-01 11:53:27 EDT
lout-3.36-2.fc9.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
Comment 1 FTBFS 2008-10-01 11:53:31 EDT
Created attachment 318590 [details]
root.log

root.log for x86_64
Comment 2 FTBFS 2008-10-01 11:53:35 EDT
Created attachment 318591 [details]
build.log

build.log for x86_64
Comment 3 FTBFS 2008-10-01 11:53:36 EDT
Created attachment 318592 [details]
mock.log

mock.log for x86_64
Comment 4 Tom "spot" Callaway 2008-10-02 13:43:16 EDT
The logs show ps2pdf segfaulting inside of libgs, specifically:

rogram received signal SIGSEGV, Segmentation fault.
names_trace_finish (nt=0x607598, gcst=0x7fffffffe7d0) at src/iname.c:418
418                     o_set_unmarked((obj_header_t *)ssub - 1);
Missing separate debuginfos, use: debuginfo-install cairo.x86_64 cups.x86_64 e2fsprogs.x86_64 expat.x86_64 gcc.x86_64 glibc.x86_64 gnutls.x86_64 jasper.x86_64 keyutils.x86_64 krb5.x86_64 libICE.x86_64 libSM.x86_64 libX11.x86_64 libXau.x86_64 libXdmcp.x86_64 libXext.x86_64 libXrender.x86_64 libgcrypt.x86_64 libgpg-error.x86_64 libjpeg.x86_64 libpng.x86_64 libselinux.x86_64 libtasn1.x86_64 libtiff.x86_64 libxcb.x86_64 pixman.x86_64 zlib.x86_64
(gdb) bt
#0  names_trace_finish (nt=0x607598, gcst=0x7fffffffe7d0) at src/iname.c:418
#1  0x00007ffff76aae32 in gs_gc_reclaim (pspaces=<value optimized out>, global=1) at src/igc.c:371
#2  0x00007ffff7721d87 in context_reclaim (pspaces=0x643948, global=1) at src/zcontext.c:283
#3  0x00007ffff7685060 in gs_vmreclaim () at src/ireclaim.c:153
#4  ireclaim (dmem=0x643940, space=8) at src/ireclaim.c:75
#5  0x00007ffff7680961 in interp_reclaim (pi_ctx_p=0x6028a8, space=8) at src/interp.c:427
#6  0x00007ffff767784c in gs_main_finit (minst=0x602810, exit_status=0, code=0) at src/imain.c:752
#7  0x00007ffff767b258 in gsapi_exit (lib=<value optimized out>) at src/iapi.c:262
#8  0x0000000000400a4c in main (argc=14, argv=<value optimized out>) at src/dxmainc.c:88

(gdb) list src/iname.c:418
413             if (sub != 0) {
414                 name_scan_sub(nt, i, true);
415                 if (nt->sub[i].names == 0 && gcst != 0) {
416                     /* Mark the just-freed sub-table as unmarked. */
417                     o_set_unmarked((obj_header_t *)sub - 1);
418                     o_set_unmarked((obj_header_t *)ssub - 1);
419                 }
420             }
421             if (i == 0)
422                 break;

For what it is worth, I cannot reproduce this on my end, normally or in mock.

I've hacked around this so that the package builds (with prebuilt PDF files), so I'm going to close out this bug and open one against ghostscript.

Note You need to log in before you can comment on or make changes to this bug.