Bug 465118 - NetworkManager fails to reconnect to a network it has connected before
NetworkManager fails to reconnect to a network it has connected before
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 12:51 EDT by Miguel Angel Perez
Modified: 2009-02-17 07:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 07:02:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Grepped /var/log/messages output (223.54 KB, text/plain)
2008-10-01 12:51 EDT, Miguel Angel Perez
no flags Details
Dmesg grepped output for wlan0 interface (16.13 KB, text/plain)
2008-10-01 13:15 EDT, Miguel Angel Perez
no flags Details
Lspci output for my wifi device (606 bytes, text/plain)
2008-10-01 13:22 EDT, Miguel Angel Perez
no flags Details
/var/log/messages grepped for NetworkManager (50.22 KB, text/plain)
2008-10-06 04:28 EDT, Miguel Angel Perez
no flags Details
Dmesg grepped output for wlan0 interface (7.57 KB, text/plain)
2008-10-06 04:29 EDT, Miguel Angel Perez
no flags Details

  None (edit)
Description Miguel Angel Perez 2008-10-01 12:51:04 EDT
Created attachment 319126 [details]
Grepped /var/log/messages output

Description of problem:
NetworkManager is unable to reconnect to a network it has already connected. When you lost the connection it starts to ask you the password again and again and shows a long string of hexadecimal characters in the password box. 

This problem have also been seen in previous versions for fedora 9 and is still unresolved in the version in rawhide.

Version-Release number of selected component (if applicable):
NetworkManager 0.7.0
Package version: 0.11.svn4022.2.fc10 

How reproducible:
Log into a wireless network, do something so the connection is lost and then let nm reconnect.This also can happen when suspending.

Steps to Reproduce:
1. Log into wireless network with wpa security
2. Enter you pass and connect to it
3. shutdown the wireless access point and start it again
  
Actual results:
Network manager asks the password in an endless loop

Expected results:
Network manager connects if the password have been previously configured in the network connection settings or it only asks it once if it is the correct password.

Additional info:
This bug should be the same as https://bugzilla.redhat.com/show_bug.cgi?id=447213, but this is reported to rawhide version of the package instead.
Comment 1 Miguel Angel Perez 2008-10-01 13:15:28 EDT
Created attachment 319130 [details]
Dmesg grepped output for wlan0 interface
Comment 2 Miguel Angel Perez 2008-10-01 13:22:05 EDT
Created attachment 319131 [details]
Lspci output for my wifi device
Comment 3 Miguel Angel Perez 2008-10-01 15:59:08 EDT
Usually if you go to options and remove the entry for the wifi connection the next authentication can be successful.

If that fails restarting the NetworkManager service helps too.
Comment 4 Miguel Angel Perez 2008-10-06 04:28:18 EDT
Created attachment 319525 [details]
/var/log/messages grepped for NetworkManager
Comment 5 Miguel Angel Perez 2008-10-06 04:29:10 EDT
Created attachment 319526 [details]
Dmesg grepped output for wlan0 interface
Comment 6 Miguel Angel Perez 2008-10-06 04:30:06 EDT
Is this applies now for fedora 9 package i'm changing from rawhide to fedora 9.
Comment 7 Miguel Angel Perez 2008-10-06 04:35:43 EDT
After the last update the package from fedora 9 repositories replaced the one from rawhide and both are now the same version.

NetworkManager-0.7.0-0.11.svn4022.4.fc9.i386

With the last update network manager asks the password again and again and doesn't connect to the wpa wifi. The above tricks doesn't work no more. This is not new, i have been experiencing random works/don't work since the first time NM was introduced in fedora as the default manager for connections.

I have updated the attachments in hope it helps to solve the painful behavior of a critical app like this.
Comment 8 oliver 2008-10-19 17:25:48 EDT
I am seeing the same, or a similar problem after the most recent system update to network manager 0.11.svn4022.4.fc9.

* Stored wireless network connections which were created with WEP ASCII key stop working (asking for the password again and again)

* It is impossible to re-enter a WEP ASCII key.  It seems the user interface has changed.  Previously there was an explicit option for entering WEP ASCII keys, now none of the remaining (48/128 bit key, 128 bit passphrase) seems to accept ASCII keys.

I fail to see the rationale of breaking a working Fedora 9 so late in its life cycle by removing critical UI options.

Only solution so far appears to downgrade network manager in order to connect to certain networks.
Comment 9 Dan Williams 2008-10-19 22:49:32 EDT
Oliver, could you file another bug report about that specific issue with ASCII keys?  The dialog should be accepting the ASCII keys, you can choose "WEP 40/128-bit Key" and it will accept either the 5 or 13 character ASCII keys.  Are you _sure_ your key is an ascii key?  How long is it?  Does it contain non-hexadecimal characters (ie, any characters other than 0 -> 9 and a -> F)?
Comment 10 Dan Williams 2008-10-19 22:51:40 EDT
Miguel, sounds more like driver issues (the supplicant clearly is not connecting to your AP).  NM uses wpa_supplicant underneath to drive the wifi connection, and the supplicant isn't getting past the 4-Way Handshake step.  Would you mind if I helped you through a wpa_supplicant manual run to see what the issue might be?

Also, what kernel version is installed?  'uname -a' from a terminal will tell you.
Comment 11 Miguel Angel Perez 2008-10-20 06:14:04 EDT
Hello Dan,

I'm using the latest PAE kernel from fedora repos, here is the uname -a output:

Linux hyperion.hegemony 2.6.26.5-45.fc9.i686.PAE #1 SMP Sat Sep 20 03:34:10 EDT 2008 i686 i686 i386 GNU/Linux

I'll be glad of following your advice to find what is the issue and do the manual run of wpa_supplicant.
Comment 12 oliver 2008-10-21 15:17:58 EDT
(In reply to comment #9)
> Oliver, could you file another bug report about that specific issue with ASCII
> keys?  The dialog should be accepting the ASCII keys, you can choose "WEP
> 40/128-bit Key" and it will accept either the 5 or 13 character ASCII keys. 

The issue I am seeing, embarassingly, disappeared after a system reboot.  Now I can indeed inter an ASCII key in the field "WEP 40/128-bit Key".  I had tried a lot of things, but a reboot after upgrading network manager had not crossed my mind (I had restarted the deamon, though, to no avail)...

Will file separate bug report should I ever be able to reproduce this problem.
Comment 13 Brittany Dunlap 2008-11-12 03:39:53 EST
I had the same problem however I was able to reconnect by using Edit Connections, delete the (auto) connected network, and create a new one, OR wait till the network is scanned again and chose it to connect to.
Comment 14 Dan Williams 2009-02-17 07:02:13 EST
Oliver; thanks for the report, closing since this is reported as fixed.  If there are other issues, please file a new bug for them.

Note You need to log in before you can comment on or make changes to this bug.