Bug 465138 - Bluetooth mouse doesn't reconnect
Bluetooth mouse doesn't reconnect
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 15:15 EDT by Jeremy Fitzhardinge
Modified: 2008-12-14 17:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 10:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2008-10-01 15:15:04 EDT
Description of problem:
When I pair a bluetooth mouse it works fine.  But it won't reconnect itself.  I need to remove the pairing and re-pair it each time.

Version-Release number of selected component (if applicable):
$ rpm -qa bluez*
bluez-cups-4.9-1.fc10.x86_64
bluez-libs-4.9-1.fc10.x86_64
bluez-gnome-1.6-1.fc10.x86_64
bluez-alsa-4.9-1.fc10.x86_64
bluez-4.9-1.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Pair mouse
2. Reboot
3. Try to use mouse
  
Actual results:
Mouse doesn't reconnect.  Won't work until I remove the pairing and re-pair.

Expected results:
Mouse automatically connects and is usable.

Additional info:
Mouse is "HP Bluetooth Laser Mobile Mouse".
Comment 1 Bastien Nocera 2008-10-01 15:29:52 EDT
Do you see any relevant messages in /var/log/messages when you turn the mouse back on? What's the output of "dbus-monitor --system" when you're logged in and turn the mouse back on?
Comment 2 Jeremy Fitzhardinge 2008-10-01 15:51:30 EDT
There are no messages in /var/log/messages or in dmesg when I turn power back on.  If I push the "pair" button on the mouse and manually run "hidd --search" it starts working again.
Comment 3 Jeremy Fitzhardinge 2008-10-01 15:52:05 EDT
BTW, in F9 I had to manually pair by running hidd --search, but it reconnected properly thereafter.
Comment 4 Bastien Nocera 2008-10-01 18:59:06 EDT
Don't use hidd in F10. It will conflict with the input service in bluetoothd.

I'm also waiting for the output of "dbus-monitor --system" when you turn the mouse back on.

You might want to try, after pairing the mouse, to set it as a trusted device in the bluetooth preferences, and try again, see if it connects again correctly.
Comment 5 Jeremy Fitzhardinge 2008-10-01 19:11:49 EDT
I get this when I turn the mouse off:

signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Device; member=PropertyChanged
   string "Connected"
   variant       boolean false
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Input; member=Disconnected
signal sender=:1.0 -> dest=(null destination) path=/org/freedesktop/Hal/Manager; interface=org.freedesktop.Hal.Manager; member=DeviceRemoved
   string "/org/freedesktop/Hal/devices/bluetooth_acl_ff66d32c6_logicaldev_input"
signal sender=:1.0 -> dest=(null destination) path=/org/freedesktop/Hal/Manager; interface=org.freedesktop.Hal.Manager; member=DeviceRemoved
   string "/org/freedesktop/Hal/devices/bluetooth_acl_ff66d32c6"

And nothing when I turn it on again.

When I remove the device and re-pair, I get:

signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0; interface=org.bluez.Adapter; member=PropertyChanged
   string "Discovering"
   variant       boolean false
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Device; member=PropertyChanged
   string "Connected"
   variant       boolean true
signal sender=:1.0 -> dest=(null destination) path=/org/freedesktop/Hal/Manager; interface=org.freedesktop.Hal.Manager; member=DeviceAdded
   string "/org/freedesktop/Hal/devices/bluetooth_acl_ff66d32c6"
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Device; member=PropertyChanged
   string "Name"
   variant       string "HP Bluetooth Laser Mobile Mouse"
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Device; member=PropertyChanged
   string "Alias"
   variant       string "HP Bluetooth Laser Mobile Mouse"
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Device; member=PropertyChanged
   string "UUIDs"
   variant       array [
         string "00001000-0000-1000-8000-00805f9b34fb"
         string "00001124-0000-1000-8000-00805f9b34fb"
         string "00001200-0000-1000-8000-00805f9b34fb"
      ]
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0; interface=org.bluez.Adapter; member=DeviceCreated
   object path "/org/bluez/hci0/dev_00_0F_F6_6D_32_C6"
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0; interface=org.bluez.Adapter; member=PropertyChanged
   string "Devices"
   variant       array [
         string "/org/bluez/hci0/dev_00_0F_F6_6D_32_C6"
      ]
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Input; member=Connected
signal sender=:1.0 -> dest=(null destination) path=/org/freedesktop/Hal/Manager; interface=org.freedesktop.Hal.Manager; member=DeviceAdded
   string "/org/freedesktop/Hal/devices/bluetooth_acl_ff66d32c6_logicaldev_input"
signal sender=:1.5 -> dest=(null destination) path=/org/freedesktop/NetworkManager/AccessPoint/5; interface=org.freedesktop.NetworkManager.AccessPoint; member=PropertiesChanged
   array [
      dict entry(
         string "Strength"
         variant             byte 100
      )
   ]
signal sender=org.freedesktop.DBus -> dest=(null destination) path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.104"
   string ":1.104"
   string ""
signal sender=:1.92 -> dest=(null destination) path=/org/freedesktop/PackageKit; interface=org.freedesktop.PackageKit; member=TransactionListChanged
   array [
      string "/22_eabaedce_data"
      string "/23_bbeacaee_data"
      string "/26_dbbaccec_data"
      string "/27_eeeabeac_data"
   ]
signal sender=:1.8 -> dest=(null destination) path=/org/bluez/hci0/dev_00_0F_F6_6D_32_C6; interface=org.bluez.Device; member=PropertyChanged
   string "Trusted"
   variant       boolean true


Setting it to trusted didn't help.
Comment 6 Bastien Nocera 2008-10-13 07:06:10 EDT
Could you please test with bluez 4.13?

My mouse reconnects fine, turning it off and on again, but sometimes doesn't show up as connected in the preferences.

You can double-check whether the connection is up using "hidd --show" on the command-line.
Comment 7 Jeremy Fitzhardinge 2008-10-13 10:54:10 EDT
4.13 doesn't help.

If I do a fresh pairing, hidd --show says:
00:0F:F6:6D:32:C6 HP Bluetooth Laser Mobile Mouse [0d62:0558] connected 

I turn the mouse off and it disappears from hidd --show after ~10-20 seconds.

It does not reappear in hidd --show when I turn the mouse on again.

When I explicitly re-pair it, it works again.
Comment 8 Jeremy Fitzhardinge 2008-10-14 16:10:56 EDT
No change with bluez-4.13-2.fc10.x86_64
Comment 9 Jeremy Fitzhardinge 2008-10-14 16:11:40 EDT
Is there any further logging/debugging I can do to help with this?
Comment 10 Jeremy Fitzhardinge 2008-10-15 15:42:25 EDT
Ah!  If I set the visibility setting to "temporarily visible" then the mouse reconnects fine.  Presumably if I make it always visible then it would also reconnect consistently.

Is it really necessary to make the computer always visible?
Comment 11 Bastien Nocera 2008-10-15 17:58:36 EDT
Thanks for looking into that further. This problem sounds really bad to me, and surely is a bug in the mouse itself. I tested this with my dirt cheap Bluetooth mouse[1], and it re-connected without any manual intervention even with the adapter hidden.

What model of mouse is it? Does it behave in a similar way in other operating systems (eg. Windows or MacOS X)?

If your Bluetooth mouse is the main mouse on a desktop system, or a docked laptop system, it might work better in the future with:
http://bugzilla.gnome.org/show_bug.cgi?id=556301

[1]: http://www.amazon.co.uk/TRUST-MI-5300M-BLUETOOTH-OPTICAL-MINI-MOUSE/dp/B00070GX18/
Comment 12 Jeremy Fitzhardinge 2008-10-15 18:11:35 EDT
It's a Hewlett Packard N558 "HP Bluetooth Laser Mouse", bought from the smoking ruins of a collapsing CompUSA store.  I use it with my laptop, so fortunately I always have the nub as a spare to navigate while getting the mouse working.  I don't dock the laptop, and carry the mouse about with me.

The mouse worked perfectly with F9, so this is a pure regression from my perspective.  Its possible, however, that my F9 laptop was set to be always discoverable (I'll check when I get home; however I don't think that's true because it doesn't sound like the kind of thing I'd do).

I haven't tried it with MacOS.  I tried it briefly with Windows, but I don't think I tested reconnection.
Comment 13 Jeremy Fitzhardinge 2008-10-15 19:50:00 EDT
OK, strange.  Having set the computer's visibility setting to "temporarily visible" *once*, the mouse is now happily automatically reconnecting, even with the computer now set to "hidden".

I'll see what happens next time I either suspend or reboot the machine...
Comment 14 Jeremy Fitzhardinge 2008-10-23 14:17:29 EDT
This is now working fine for me, even if I leave the computer as "hidden" in the visibility setting.  It seems that having made it visible once, something is now happy.
Comment 15 Bastien Nocera 2008-10-24 06:30:18 EDT
Removing from the F10 Desktop target, I'll document this on the Fedora wiki.
Comment 16 Bastien Nocera 2008-10-28 10:48:44 EDT
Mentioned in the docs now:
https://fedoraproject.org/wiki/Documentation/Bluetooth

Thanks!
Comment 17 Alex 2008-12-14 17:41:56 EST
I have had the same problem. 
This topic has helped me so much to solve it, BUT
it seems to me that it IS A BUG though.

I have a BT mouse Genius Navigator 900 PRO and it works perfectly well on windows xp, and it worked perfectly well on Fedora 8.

and on fedora 8 i have NOT made any tricks such as described above to make it reconnect automatically...

so.. i think it is a bug.

Note You need to log in before you can comment on or make changes to this bug.