Bug 465145 - compiz crashes xorg-x11-drv-i810-2.4.2-9.fc10.x86_64
compiz crashes xorg-x11-drv-i810-2.4.2-9.fc10.x86_64
Status: CLOSED DUPLICATE of bug 444328
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 15:40 EDT by Thomas J. Baker
Modified: 2009-09-06 04:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:55:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log.old (25.27 KB, text/plain)
2008-10-01 15:40 EDT, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2008-10-01 15:40:27 EDT
Created attachment 319158 [details]
Xorg.0.log.old

Updated from rawhide today, no X apparently due to kernel drm changes (something about gem). Immediately went to koji and found xorg-x11-drv-i810-2.4.2-9.fc10.x86_64 whose changelog addresses issue precisely (koji makes testing rawhide so much more rewarding!) 

Now I get X but when I log in, it crashes when compiz starts. Nothing remarkable in the Xorg log (included) except the "exaCopyDirty: Pending damage region empty!" line. 

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])

I disabled compiz and all 3d apps (glxgears, supertux) segfault. I then tried compiz again and it crashed the x server.

Also, I'm running without a xorg.conf file. Are there any tricks to speeding up 3d to Fedora 8 speeds?
Comment 1 Matěj Cepl 2008-10-02 07:10:15 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Also try with nomodeset on the kernel command line (press a in grub menu). Does it help?

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Thomas J. Baker 2008-10-02 08:58:14 EDT
Adding nomodeset didn't help, it crashed like before. And as I said before, I'm not using an xorg.conf file so the already included X log is for the no conf file case.
Comment 3 Thomas J. Baker 2008-10-02 13:53:27 EDT
After today's updates from rawhide, I no longer get a crash with compiz, and glxgears runs without segfaulting (probably the mesa updates helped?) 

Now glxgears pins one cpu like it's doing software rendering or something. glxinfo shows direct rendering supported but glxgears is getting 210FPS when I used to get about 1200FPS. In general, 3d support is pretty slow.
Comment 4 Bug Zapper 2008-11-25 22:25:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Vedran Miletić 2009-09-06 03:55:06 EDT

*** This bug has been marked as a duplicate of bug 444328 ***
Comment 6 Vedran Miletić 2009-09-06 04:02:16 EDT
Bug is fixed; comment #3 is duplicate of bug 444328.

Note You need to log in before you can comment on or make changes to this bug.