This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 465148 - openibd start script is printing out an error msg
openibd start script is printing out an error msg
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openib (Show other bugs)
5.3
All Linux
medium Severity low
: rc
: ---
Assigned To: Doug Ledford
Gurhan Ozen
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 15:55 EDT by Gurhan Ozen
Modified: 2013-11-03 20:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:41:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2008-10-01 15:55:17 EDT
Description of problem:


# service openibd start
Loading OpenIB kernel modules:Usage: udevtrigger [--verbose] [--dry-run]
                                                           [  OK  ]



Version-Release number of selected component (if applicable):
openib-1.3.2-0.20080728.0355.1.el5

How reproducible:
Very, everytime.

Steps to Reproduce:
1. Install  openib-1.3.2-0.20080728.0355.1.el5 from errata 2009:8171
2. service openibd start	
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gurhan Ozen 2008-10-01 16:10:22 EDT
Updating the title of the bug since it's misleading...
Comment 2 Doug Ledford 2008-10-02 08:37:12 EDT
This means that the rhel5 udevtrigger can't handle the same options as the fedora9 udevtrigger.  I'll need to switch the openibd script back to using hwconf on rhel instead of udevtrigger.
Comment 8 Gurhan Ozen 2008-10-14 07:00:24 EDT
The new package fixes this particular issue. However , after upgrading to the new package, openibd script doesn't load ib_mthca module even though there is a Mellanox HCA on the box, until it reboots. After the box is rebooted once, it loads ib_mthca module just fine. Can this be fixed?
Comment 9 Doug Ledford 2008-10-14 08:40:32 EDT
That doesn't make any sense.  If you are saying that the ib stack was down, you did an upgrade, and it stayed down, then that's correct.  We don't down/up the ib stack on upgrade (it could cause way too many problems).  If you are saying that you upgraded and then rebooted and it didn't come up, and then you rebooted again and it came up after that, then that wouldn't make any sense either.  You'll need to be a bit more specific on what the problem actually is and how it manifested itself.
Comment 11 Doug Ledford 2008-10-14 11:46:38 EDT
Put the errata in need respin and I'll get the fixed script in.
Comment 12 Doug Ledford 2008-10-14 12:14:30 EDT
new package with fixed init script added to errata
Comment 14 errata-xmlrpc 2009-01-20 16:41:03 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0170.html

Note You need to log in before you can comment on or make changes to this bug.