This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 465160 - Stop tramping over /etc/yum.conf when run either in test mode or livecd
Stop tramping over /etc/yum.conf when run either in test mode or livecd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-01 16:53 EDT by James Antill
Modified: 2013-01-09 23:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 15:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-10-01 16:53:09 EDT
Description of problem:
 If you boot a liveCD and drop a .repo file into /etc/yum.repos.d then nothing happens. This is because the yum.conf on the LiveCD overrides the reposdir option, but doesn't add the normal/default directories of /etc/yum.repos.d and /etc/yum/repos.d

Version-Release number of selected component (if applicable):
Fedora 10 Beta
Comment 1 Jeremy Katz 2008-10-01 17:12:18 EDT
There's not a different yum.conf on the live image afaik....  and I just booted and it looks fine
Comment 2 Jeremy Katz 2008-10-03 15:32:32 EDT
<jeremy> geppetto: what's up with 465160?  I tried it and am not seeing anything of the sort
<geppetto> jeremy: I filed it for ajax, who then told me he might have run anaconda which (I guess?) would explain it changing the yum.conf
 jeremy: Probably just close NaB, or reassign to anaconda ... or stab ajax :)
<ajax> jeremy: livecd, text mode, run anaconda --vnc
<jeremy> geppetto/ajax: ah.  that's a very crucial piece of information not in the bug :)
Comment 3 Jeremy Katz 2008-10-03 15:43:59 EDT
And should be done now

Note You need to log in before you can comment on or make changes to this bug.