Bug 465166 - "New tab" doesn't create tab with current profile
"New tab" doesn't create tab with current profile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 17:25 EDT by Jeremy Fitzhardinge
Modified: 2008-10-26 16:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-26 16:12:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 554485 None None None Never

  None (edit)
Description Jeremy Fitzhardinge 2008-10-01 17:25:50 EDT
Description of problem:
In F9's gnome-terminal, selecting "new tab" would create a new tab with the same profile as the current tab.  In rawhide's gnome-terminal, the new tab always has the default profile.

Version-Release number of selected component (if applicable):
gnome-terminal-2.24.0-2.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Create new profile
2.Start terminal with that profile
3.Type Ctrl-Shift-T to create new tab
  
Actual results:
New default profile tab

Expected results:
New tab with current profile.

Additional info:
Comment 1 Matthias Clasen 2008-10-02 10:14:31 EDT
If you open the Profiles dialog, there is now a preference for
"Profile used when launching a new terminal".

Is that good enough for you ? 
Otherwise, you'd have to file an upstream feature request to add a  "current profile" entry to that preference.
Comment 2 Jeremy Fitzhardinge 2008-10-02 11:23:19 EDT
No, it isn't sufficient.  The current profile represents the context of what I'm working on at the moment, and if I want a new tab or window, I want it to be in the same context.  But it isn't any specific profile I want.

This seems like a rather pointless and irritating change in behaviour.  I couldn't see any likely config option, even in gconf.
Comment 3 Jeremy Fitzhardinge 2008-10-02 13:05:48 EDT
Filed as http://bugzilla.gnome.org/show_bug.cgi?id=554742
Comment 4 Jeremy Fitzhardinge 2008-10-06 19:01:02 EDT
Gnome claims bug is fixed in current gnome-terminal.  The rawhide package needs updating.
Comment 5 Jeremy Fitzhardinge 2008-10-15 16:51:54 EDT
Reopening because this isn't fixed in Fedora.  Any chance Fedora can pull in the upstream fix?  This is a major usability issue for me.
Comment 6 Matthias Clasen 2008-10-15 17:14:20 EDT
We'll get the fix with gnome-terminal 2.24.1
Comment 7 Will Woods 2008-10-15 17:50:03 EDT
In the meantime I did a scratch build with the patch from gnome bug 554485. You
can get it here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=882960
Comment 8 Jeremy Fitzhardinge 2008-10-15 18:24:06 EDT
Thanks, that works.  An unfortunate side-effect was that it lost all my keyboard shortcuts, but it wasn't hard to re-add them.

Note You need to log in before you can comment on or make changes to this bug.