Bug 465182 - Can't whois 9.4.e164.arpa (German ENUM domains)
Can't whois 9.4.e164.arpa (German ENUM domains)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 18:24 EDT by Robert Scheck
Modified: 2009-02-04 07:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 07:41:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adds enum domains support to jwhois.conf (1010 bytes, patch)
2009-01-23 05:16 EST, Vitezslav Crhonek
no flags Details | Diff

  None (edit)
Description Robert Scheck 2008-10-01 18:24:15 EDT
Description of problem:
Per default, I'm not able to do a whois to German ENUM domains (which is 
9.4.e164.arpa). If I read the configuration file correctly, I should be
able to do the following there:

"\\.9\\.4\\.e164\\.arpa$" = "whois.enum.denic.de";

"whois\\.enum\\.denic\\.de" {
        whois-server = "whois.enum.denic.de";
        query-format = "-C UTF-8 -T dn $*";
        answer-charset = "UTF-8";
}

Unluckily, it doesn't work (it always tries to query ARIN somehow), but
I'm able to query it manually and it works there:

whois -h whois.enum.denic.de 2.5.3.2.7.2.9.6.9.4.e164.arpa -- -C UTF-8 -T dn

So can somebody please put the configuration correct into the default 
configuration file and send it upstream? It shouldn't be that hard, maybe
a bit C is needed to fix, what seems to be broken somewhere (or I am just
too dumb, to put the stuff correctly into the /etc/jwhois.conf)...

Version-Release number of selected component (if applicable):
jwhois-4.0-7

Actual results:
No whois for German ENUM domains possible.

Expected results:
Whois for German ENUM domains possible.
Comment 1 Robert Scheck 2008-10-19 15:27:20 EDT
Ping?
Comment 2 Vitezslav Crhonek 2008-10-20 06:09:54 EDT
Request send to upstream, no response yet. (Unfortunately I have no luck with editing configuration file too.)
Comment 3 Bug Zapper 2008-11-25 22:26:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Vitezslav Crhonek 2009-01-23 05:14:28 EST
Hi Robert,

Still no response from Jonas:( But I investigate it a little bit... ARIN is selected because 2.5.3.2.7.2.9.6.9.4.e164.arpa matches to "\\([0-9]+\\.\\)+[0-9]+" = "struct cidr-blocks"; in jwhois.conf, then in "struct cidr-blocks" no match is found => default = "whois.arin.net"; is used.

In attachment is my proposed change. First - recognizing ENUM domain (I don't know much about these domains, so I'm not sure if this regexp is for 100 % correct), redirection to enum-domains block, where right server is selected (only whois.enum.denic.de at the moment for .9.4.e164.arpa). Server options remains as you posted them.
Comment 5 Vitezslav Crhonek 2009-01-23 05:16:47 EST
Created attachment 329789 [details]
Patch adds enum domains support to jwhois.conf
Comment 6 Robert Scheck 2009-01-23 05:40:30 EST
Vitezslav, ENUM domains are pretty simple: Take your telephone number 
(+49-800-1234), reverse it (432100894) and put a dot in between of each
number (4.3.2.1.0.0.8.9.4) and afterwards only append the .e164.arpa 
(4.3.2.1.0.0.8.9.4.e164.arpa). Of course you need a registry/NIC which
is able to handle that, Germany is doing so using DENIC.

Let me try your patch, I will come back to it with feedback.
Comment 7 Robert Scheck 2009-01-23 11:37:43 EST
Yes, that patch works for me. Thank you very much. Can we maybe get it
upstream and into Fedora, too?
Comment 8 Vitezslav Crhonek 2009-02-03 09:04:18 EST
That's a plan. But upstream is still not responding. So I'll probably put it into Rawhide during this week without upstream acceptance - I think it doesn't matter so much - it's not big change and it will be better tested in Rawhide too.
Comment 9 Vitezslav Crhonek 2009-02-04 07:41:56 EST
Good news - accepted by upstream and built in Rawhide (jwhois-4.0-10).

Note You need to log in before you can comment on or make changes to this bug.