Bug 465201 - translation reports fail on short form languages
translation reports fail on short form languages
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 00:47 EDT by Jeff Fearn
Modified: 2010-11-23 23:16 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.38
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 00:48:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2008-10-02 00:47:08 EDT
Description of problem:
Translation reports fail to generate on languages which consist of a two character language prefix. e.g. es-ES works but es fails.

Version-Release number of selected component (if applicable):
publican-0.37

How reproducible:
Always

Steps to Reproduce:
1. Add a two character language to a book
2. make publish-report
3.
  
Actual results:
"Use of uninitialized value $language in string eq at
/usr/bin/StSe_Reports line 72."

Expected results:
Shiny translation report

Additional info:
Comment 1 Jeff Fearn 2008-10-02 00:48:40 EDT
Fixed uninitialized value.

Reworked HTML and CSS since they hurt my eyes.
Comment 2 Fedora Update System 2008-10-16 18:43:43 EDT
publican-0.38-0.fc9,perl-XML-TreeBuilder-3.09-11.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/publican-0.38-0.fc9,perl-XML-TreeBuilder-3.09-11.fc9
Comment 3 Fedora Update System 2008-11-06 21:54:59 EST
publican-0.38-0.fc9, perl-XML-TreeBuilder-3.09-11.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.