This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 465203 - RFE: Upgrade bouncycastle to the latest version
RFE: Upgrade bouncycastle to the latest version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bouncycastle (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: itext
  Show dependency treegraph
 
Reported: 2008-10-02 01:25 EDT by Orcan Ogetbil
Modified: 2008-10-03 13:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 12:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orcan Ogetbil 2008-10-02 01:25:13 EDT
Description of problem:
The current version of bouncycastle is 1.38 for F-9, and 1.39 for rawhide, which are both relatively old. 

Currently there is a version 1.41 out with significant improvements as listed in http://www.bouncycastle.org/releasenotes.html

Also the code for the patented IDEA algorithm is removed from the default tarball and hence it will be a smoother upgrade.

And a personal request: I will greatly appreciate if bcmail-1.41 is included in the package since iText (which I was thinking of de-obsoleting) depends both on bcprov and bcmail.

Version-Release number of selected component (if applicable):
1.38 for F-9
1.39 for rawhide
Comment 1 Lillian Angel 2008-10-02 12:05:19 EDT
Upgraded bouncycastle to 1.41. Should be in rawhide within the next couple of days
Comment 2 Orcan Ogetbil 2008-10-02 16:57:32 EDT
I decided to take over bcmail by packaging it as bouncycastle-mail. But I have one question that concerns both bouncycastle and bouncycastle-mail.

Does bouncycastle really have BSD license (as I saw in the spec file of last package in koji)? Please observe:
http://www.bouncycastle.org/licence.html

This license file can be found in both bcprov and bcmail tarballs.
Comment 3 Kevin Kofler 2008-10-03 07:50:56 EDT
Sounds like it's a variant of the MIT X11 license, i.e. it should actually say License: MIT, not License: BSD.

Note You need to log in before you can comment on or make changes to this bug.