Bug 465209 - Can't install both libusb-devel.i386 and libusb-devel.x86_64
Can't install both libusb-devel.i386 and libusb-devel.x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libusb (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 02:03 EDT by Jeremy Fitzhardinge
Modified: 2013-07-02 19:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 08:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2008-10-02 02:03:27 EDT
Description of problem:
Can't install both libusb-devel.i386 and libusb-devel.x86_64 due to conflicting files.

Version-Release number of selected component (if applicable):
0.1.12-15

How reproducible:
Always

Steps to Reproduce:
1. yum install libusb-devel.i386 libusb-devel.x86_64
2.
3.
  
Actual results:
Install fails.

Expected results:
Install succeeds.

Additional info:
yum install libusb-devel.i386 libusb-devel.x86_64
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package libusb-devel.i386 0:0.1.12-15.fc9 set to be updated
--> Processing Dependency: libusbpp-0.1.so.4 for package: libusb-devel
--> Processing Dependency: libusb-0.1.so.4 for package: libusb-devel
---> Package libusb-devel.x86_64 0:0.1.12-15.fc9 set to be updated
--> Running transaction check
---> Package libusb.i386 0:0.1.12-15.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package             Arch          Version              Repository        Size 
================================================================================
Installing:
 libusb-devel        x86_64        0.1.12-15.fc9        rawhide            77 k
 libusb-devel        i386          0.1.12-15.fc9        rawhide            77 k
Installing for dependencies:
 libusb              i386          0.1.12-15.fc9        rawhide            28 k

Transaction Summary
================================================================================
Install      3 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 183 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/doc/libusb-devel-0.1.12/manual.ps conflicts between attempted installs of libusb-devel-0.1.12-15.fc9.x86_64 and libusb-devel-0.1.12-15.fc9.i386

Error Summary
-------------
Comment 1 Jindrich Novy 2008-10-06 08:49:19 EDT
It was caused by different timestamps in the postscript file generated by docbook2ps. It is now fixed in rawhide libusb-0.1.12-18.

Note You need to log in before you can comment on or make changes to this bug.