Bug 465211 - korganizer freezing
korganizer freezing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 02:56 EDT by Csaba Ortutay
Modified: 2009-03-25 12:10 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.5.10-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kcrash file for korganizer (4.31 KB, text/plain)
2008-10-02 02:56 EDT, Csaba Ortutay
no flags Details
Kcrash report of korganizer with debuginfo (2.74 KB, text/plain)
2008-10-02 03:45 EDT, Csaba Ortutay
no flags Details

  None (edit)
Description Csaba Ortutay 2008-10-02 02:56:11 EDT
Created attachment 319193 [details]
Kcrash file for korganizer

Description of problem:
korganizer (the calendar part of kontact) is freezing either strated standalone or as part of kontact.

I use calendars stored in distant files, aka. ics format calendars stored at http://www.icalx.com. Up to now they have worked as expected. After a recent update (I am not sure, but during the last few weeks, let's say 3 weeks) the calendar program started to freeze. Normally I use korganizer in kontact. When I swich to the calendar (eg. from mails) it show up, but after 2-3 secs it just crash, and the whole kontact crash together. I suspect that it is when it tries to sync with the network stored ics file. (I have tried, thinderbird ligthning can use the ics files well, so that part is ok.)

When I start from command line, after the crash I see these messages:

QGDict::hashKeyString: Invalid null key
QGDict::hashKeyString: Invalid null key
KCrash: Application 'korganizer' crashing...

I attach the kcrash report for korganizer. The file is almost the same for kontact crash.


Version-Release number of selected component (if applicable):
kdepim.i386 - 6:3.5.10-1.fc9

How reproducible:

It happens always for me.


Steps to Reproduce:
1. Start korganizer (or kontact). Set up a calendar stored in distant file. It should be an ics file stored at http://www.icalx.com (free registration).
2. Restart korganizer, or switch to the calendar in kontact. 
3. The program will crash in a few seconds, but not immediately.
  
Actual results:
korganized crash

Expected results:
not crash.

Additional info:
Comment 1 Kevin Kofler 2008-10-02 03:20:54 EDT
The offending update must have been the kdepim 3.5.10 update.

Unfortunately, your backtrace does not contain any line numbers because you do not have debugging information installed. Could you please install the relevant debugging information with:
su -c "debuginfo-install kdepim"
and post the resulting backtrace? See:
https://fedoraproject.org/wiki/StackTraces
for more information.
Comment 2 Csaba Ortutay 2008-10-02 03:45:28 EDT
Created attachment 319196 [details]
Kcrash report of korganizer with debuginfo

This is the kcrash report on korganizer after I have installed the debuginfo packages.
Comment 3 Kevin Kofler 2008-10-02 03:52:32 EDT
The offending line:
>  if ( mIncidence->type() == "Todo" ) {

There's a comment earlier in that function:
  //HACK
  // to reproduce a crash:
  // 1. start Kontact with the Calendar as the initial module
  // 2. immediately select the summary (which must include appt and to-do)
  // causes a crash for me every time in this method unless we make
  // the following check
  if ( !mIncidence )return;
but apparently mIncidence can't just be NULL, it can also be an invalid pointer. :-(
Comment 4 Kevin Kofler 2008-10-02 04:05:35 EDT
Looks like this might be the same bug as:
https://bugs.kde.org/show_bug.cgi?id=171651
However, that bug is filed against 4.1.67, this is 3.5.10, apparently the bug got backported. :-(

There's also another upstream bug with the same backtrace (crash at the same line):
https://bugs.kde.org/show_bug.cgi?id=171787
but triggered by different user actions.
Comment 5 Csaba Ortutay 2008-10-02 04:42:41 EDT
(In reply to comment #4)
> There's also another upstream bug with the same backtrace (crash at the same
> line):
> https://bugs.kde.org/show_bug.cgi?id=171787
> but triggered by different user actions.

I have found this too but for me it also crashes in other than week views.
Comment 6 Kevin Kofler 2008-10-02 04:48:43 EDT
Yours sounds more like https://bugs.kde.org/show_bug.cgi?id=171651 .
Comment 7 Kevin Kofler 2009-03-15 21:29:29 EDT
This is fixed in 4.2.1 by:
http://websvn.kde.org/?view=rev&revision=924024

I'll see if I can backport this to F9's kdepim 3.5.10.
Comment 8 Kevin Kofler 2009-03-15 21:50:09 EDT
Fix committed to CVS, 3.5.10-3.fc9 now building in Koji.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1242710
Comment 9 Kevin Kofler 2009-03-15 22:26:11 EDT
New build attempt (the above build failed due to an issue with KMail and the current kernel headers):
http://koji.fedoraproject.org/koji/taskinfo?taskID=1242748
Comment 10 Fedora Update System 2009-03-16 00:59:39 EDT
kdepim-3.5.10-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kdepim-3.5.10-3.fc9
Comment 11 Fedora Update System 2009-03-16 15:48:16 EDT
kdepim-3.5.10-3.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update kdepim'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2750
Comment 12 Fedora Update System 2009-03-25 12:10:52 EDT
kdepim-3.5.10-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.