Bug 465217 - Xorg fails to start after updating rawhide on Oct 2nd
Xorg fails to start after updating rawhide on Oct 2nd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 04:09 EDT by Juraci Paixão Kröhling
Modified: 2008-10-02 09:37 EDT (History)
0 users

See Also:
Fixed In Version: xorg-x11-drv-i810-2.4.2-9.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 09:37:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log for the problem. (11.90 KB, text/x-log)
2008-10-02 04:09 EDT, Juraci Paixão Kröhling
no flags Details
xorg.conf file (645 bytes, text/plain)
2008-10-02 04:11 EDT, Juraci Paixão Kröhling
no flags Details
:2.log file, from /var/log/gdm (6.79 KB, text/x-log)
2008-10-02 04:24 EDT, Juraci Paixão Kröhling
no flags Details

  None (edit)
Description Juraci Paixão Kröhling 2008-10-02 04:09:07 EDT
Created attachment 319198 [details]
Xorg log for the problem. 

Description of problem:
After applying the night's updates (41 or 61 updates, I can't remember), the X doesn't starts anymore. There's no "EE" in the X.n.log and the screen keeps "flickering", suggesting that X is trying to start. It seems that the other consoles are not active, because I cannot open them by using ctrl+alt+fn. So, I have to issue a "ctrl+alt+del" to reboot.

Version-Release number of selected component (if applicable):
Rawhide, updated from "everything updated at 10pm UTC Oct 1st" to "everything updated at 8:30am UTC Oct 2nd". 
Hardware: Lenovo T61

How reproducible:
Always, when X tries to start. 

Steps to Reproduce:
1. Apply the updates
2. Reboot
  
Actual results:
Screen keeps flickering, suggesting that X is trying to start. 

Expected results:
X starts fine, as it did before the update.

Additional info:
Even trying to boot from older kernels (tried 370) the problem happens. So, I don't think this is a kernel problem, but this may be somewhat related to #464775 .
Comment 1 Juraci Paixão Kröhling 2008-10-02 04:11:13 EDT
Created attachment 319199 [details]
xorg.conf file 

It had 'Screen 0 "Screen0" 0 0' before, but the same problems happens with both configurations.
Comment 2 Juraci Paixão Kröhling 2008-10-02 04:24:54 EDT
Created attachment 319201 [details]
:2.log file, from /var/log/gdm

This one seems to have more information. Suspicions line at the bottom of the file:

/usr/bin/Xorg: symbol lookup error: /usr/lib/xorg/modules/drivers//intel_drv.so: undefined symbol: intel_bufmgr_gem_init
Comment 3 Juraci Paixão Kröhling 2008-10-02 05:10:15 EDT
Downgrading from xorg-x11-drv-i810-2.4.2-8.fc10.i386 to xorg-x11-drv-i810-2.3.2-2.fc9.i386 is a workaround. 

But doing that, the problem reported on bug 464775 starts to happen.
Comment 4 Matěj Cepl 2008-10-02 07:28:13 EDT
Try the new package, but add nomodeset on the kernel command line http://fedoraproject.org/wiki/Releases/10/Beta/ReleaseNotes#Boot_up Does it help?
Comment 5 Juraci Paixão Kröhling 2008-10-02 08:11:31 EDT
"nomodeset" in the latest kernel, with the latest packages (including xorg-x11-drv-i810-2.4.2-8.fc10.i386) doesn't helps. The same symptoms happens, including the message "/usr/bin/Xorg: symbol lookup error: /usr/lib/xorg/modules/drivers//intel_drv.so: undefined symbol: intel_bufmgr_gem_init" at the end of the logs in /var/log/gdm/:n.log

Note You need to log in before you can comment on or make changes to this bug.