Bug 465220 - system-config-network crashes on PS3
system-config-network crashes on PS3
Status: CLOSED DUPLICATE of bug 468355
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 05:03 EDT by Kazunori Asayama
Modified: 2008-10-24 23:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 23:47:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message by system-config-netwrok-cmd (2.51 KB, text/plain)
2008-10-02 05:03 EDT, Kazunori Asayama
no flags Details
tree /sys (275.51 KB, text/plain)
2008-10-02 05:06 EDT, Kazunori Asayama
no flags Details
Fix crash with getVendor() == None (862 bytes, patch)
2008-10-24 08:43 EDT, Kazunori Asayama
no flags Details | Diff

  None (edit)
Description Kazunori Asayama 2008-10-02 05:03:56 EDT
Created attachment 319202 [details]
error message by system-config-netwrok-cmd

Description of problem:

The system-config-network crashes on PLAYSTATION 3 because of unhandled exception.

Version-Release number of selected component (if applicable):

Fedora 10 (Beta, rawhide)
system-config-network-1.5.10-1.fc9.noarch.rpm
system-config-network-tui-1.5.10-1.fc9.noarch.rpm

How reproducible:

Every time.

Steps to Reproduce:
1. Run system-config-network-cmd on PS3.

  
Actual results:

The system-config-network crashes with unhandled exception. See the attached log.


Expected results:

The system-config-network starts correctly.


Additional info:

The system-config-network works on Mac G5 and x86 PC.
Comment 1 Kazunori Asayama 2008-10-02 05:06:35 EDT
Created attachment 319203 [details]
tree /sys
Comment 2 Kazunori Asayama 2008-10-24 08:43:54 EDT
Created attachment 321403 [details]
Fix crash with getVendor() == None

NCBackendHal.getDevices() doesn't seem to consider getVendor() may return 'None'. Attached patch should fix this problem.

Is there any chance to apply this fix to F10?
Comment 3 Doug Chapman 2008-10-24 15:30:56 EDT
I ran into this as well and the patch in comment #2 resolves the issue for me.  I second the request to get this into F10.
Comment 4 Matthias Clasen 2008-10-24 23:47:05 EDT

*** This bug has been marked as a duplicate of bug 468355 ***

Note You need to log in before you can comment on or make changes to this bug.