Bug 465231 - 15 partitions limit on IDE discs
15 partitions limit on IDE discs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 06:48 EDT by QingLong
Modified: 2009-02-04 09:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-04 01:11:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description QingLong 2008-10-02 06:48:54 EDT
Description of problem:
Fedora 7 and later always use ide-scsi emulation to handle all ATA discs
and thus allow no more than 15 partitions on them.

Version-Release number of selected component (if applicable):
Fedora 7, 8, 9

How reproducible:
100%

Steps to Reproduce:
Either try to upgrade IDE-based installation that has more than 15 partitions on a disc, or just try to get more than 15 partitions on a fresh disc during installation. You'll fail.

Actual results:
``64k should be enough memory for anybody'' :/

Expected results:
Fedora either should allow to disable ide-scsi and treat IDE discs as hd* devices,
or provide dynamic block devices allocation mechanism for sd* partitions.

Additional info:
Don't tell me about LVM, it's inapplicable in my situation due to resource overhead and portability problems.
Comment 1 Pete Zaitcev 2008-10-02 14:25:57 EDT
Well, what are we supposed to do about that?

I actually wrote a patch that moved bits of minor around in a somewhat
compatible way, but nobody was interested:
 http://lkml.org/lkml/2006/9/7/259

The issue is, why add all this complexity when nobody in their right
mind should've configured their system this way?

I suggest backup and restore.
Comment 2 QingLong 2008-10-03 10:14:07 EDT
 Pete Zaitcev said:
>
> nobody in their right mind should've configured their system this way
>
   You live in Redmond, don't you?
Comment 3 Pete Zaitcev 2008-10-03 12:32:48 EDT
Looks that we can close this, does the requestor agree?
Comment 4 QingLong 2008-10-03 13:01:26 EDT
I wonder, has this Fedora disability already been fixed for this to be closed?
I guess, no. So, what is the last question above about?

Why it's not possible to let user disable ide-scsi emulation in order to get
IDE dics treated as they were always treated before (i.e. use hd* devices)?

If one ``in his right mind'' cannot imagine installation utilizing numerous
partitions that doesn't mean such installations do not exist or
that they should not exist. There are lots of reasons to have systems configured
quite in this way (at least in the cases I apply them).
Comment 5 Pete Zaitcev 2008-10-03 16:36:05 EDT
Jejb told me that Tejun is working on a patch similar to mine, only better.
It's going to have dynamic minors etc. I've not seen how it looks yet,
and what the naming scheme is going to be (e.g. sd0aaa or something).
I expect Fedora to ship it once the interfaces stabilize.

But the old IDE driver is dead and buried.
Comment 6 Chuck Ebbert 2008-10-04 01:11:24 EDT
(In reply to comment #4)
> 
> Why it's not possible to let user disable ide-scsi emulation in order to get
> IDE dics treated as they were always treated before (i.e. use hd* devices)?
> 

There is no ide-scsi emulation in use. We are using the new libata subsystem.

This bug should get fixed upstream, but it may take a while.
Comment 7 QingLong 2009-02-04 09:15:13 EST
Tejun Heo has told me that the 2.6.28 kernel would have the ``extended devt'',
thus allowing to handle numerous (at least more than 15) partitions on a disc
(no matter is it IDE or SCSI). So the question is:
will the extended devt be supported in the upcoming Fedora release?

Note You need to log in before you can comment on or make changes to this bug.