Bug 465245 - Tracing does not work
Tracing does not work
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gprolog (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 08:32 EDT by Roberto Bagnara
Modified: 2008-10-14 11:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 11:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roberto Bagnara 2008-10-02 08:32:06 EDT
Description of problem:

Tracing does not work: with the tracer activated even a very
simple goal fails.

Version-Release number of selected component (if applicable):

$ rpm -q gprolog
gprolog-1.3.0-17.fc8

How reproducible:

$ gprolog
GNU Prolog 1.3.0
By Daniel Diaz
Copyright (C) 1999-2007 Daniel Diaz
| ?- trace.
The debugger will first creep -- showing everything (trace)

yes
{trace}
| ?- X=1.

no
{trace}
| ?-
Comment 1 Roberto Bagnara 2008-10-02 08:34:20 EDT
This bug is there since at least Fedora 6.
Comment 2 Jochen Schmitt 2008-10-05 14:44:53 EDT
Thank you, that you have take the time to report this bug. Unfortunately, I could not find a quick solution for your issue. So I have forwarded this issue to the upstream author.

Best Regards:

Jochen Schmitt
Comment 3 Jochen Schmitt 2008-10-12 13:35:30 EDT
Uprsteam wrote that this bug is caused by gcc >= 4 and should be fixed in the upcomming release 1.3.1.

Note You need to log in before you can comment on or make changes to this bug.