Bug 465250 - Retrieving install.img... stuck at 100%
Retrieving install.img... stuck at 100%
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 465468 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 08:46 EDT by James Laska
Modified: 2013-09-02 02:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-02 16:28:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (tty3) (89.66 KB, image/png)
2008-10-02 08:52 EDT, James Laska
no flags Details
Screenshot (tty4) (83.95 KB, image/png)
2008-10-02 08:53 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-10-02 08:46:20 EDT
+----------------------------+ Retrieving +----------------------------+    
  |                                                                      |    
  | Retrieving install.img...-                                           |    
  |                                                                      |    
  |                                 100%                                 |    
  |                                                                      |    
  +----------------------------------------------------------------------+    

Versions tested:
 * rawhide 20081001
 * anaconda-11.4.1.42-1

A screenshot of tty3 can be seen at - http://jlaska.fedorapeople.org/rawhide.png

Steps to reproduce:
 1. PXE boot off the network
 2. Select lang=en, keymap=us
 3. Select a valid NIC
 4. Select DHCP
 5. Enter a URL of http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os

Additional notes:

 * have tested using a URL with a hostname, and an IP (66.187.224.20) ... same result
Comment 1 James Laska 2008-10-02 08:52:46 EDT
Created attachment 319226 [details]
Screenshot (tty3)
Comment 2 James Laska 2008-10-02 08:53:19 EDT
Created attachment 319227 [details]
Screenshot (tty4)
Comment 3 Will Woods 2008-10-02 13:52:53 EDT
Running a (non-PXE) install on x86_64 fails the same way.
Note that the last message from the kernel (tty4) is the same as yours:
  ISOFS: Unable to identify CD-ROM format.

The last message on tty5 is:
  Running... /bin/mount -n -t iso9660 -o ro,loop=/dev/loop0 /tmp/install.img /mnt/runtime

which is odd, since install.img isn't iso9660 - it's squashfs. There's no mention of squashfs anywhere.
Comment 4 Chris Lumens 2008-10-02 14:15:09 EDT
We try to mount the install.img as a variety of filesystem types, always have.  It looks to me like we are getting hung up in the loop of reading output from mount and are never getting around to trying the next filesystem type.  See mountLoopback and doMultiMount in loader.
Comment 5 Chris Lumens 2008-10-03 11:05:30 EDT
*** Bug 465468 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.