Bug 465281 - evince built without dbus support, breaks window size saving
evince built without dbus support, breaks window size saving
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-02 11:26 EDT by Dan Winship
Modified: 2008-10-27 09:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 16:43:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix (1.05 KB, patch)
2008-10-14 15:01 EDT, Dan Winship
no flags Details | Diff

  None (edit)
Description Dan Winship 2008-10-02 11:26:58 EDT
evince 2.24.0-1.fc10 got built without dbus support somehow:

checking for DBUS... 
no
configure: WARNING: DBUS support is disabled since dbus 0.70 or higher was not found

(from http://kojipkgs.fedoraproject.org/packages/evince/2.24.0/1.fc10/data/logs/i386/build.log)

It has dbus-devel listed as a BuildRequires, so I'm not sure what's wrong.


The most noticeable result of this is that evince no longer remembers window size/position/sidebar-state/etc between sessions. (I have no idea why that's dependent on dbus support, but it is.)
Comment 1 Dan Winship 2008-10-14 15:01:03 EDT
Created attachment 320342 [details]
patch to fix

it was requiring dbus-devel, but needs to be requiring dbus-glib-devel
Comment 2 Matthias Clasen 2008-10-25 00:50:22 EDT
Can you build this please, Dan ?
Comment 3 Matthias Clasen 2008-10-25 16:43:08 EDT
Nevermind, I've built it.
Comment 4 Dan Winship 2008-10-27 09:47:36 EDT
(i'd tried to just fix it myself before I attached the patch here, but ran into acl problems)

Note You need to log in before you can comment on or make changes to this bug.