Bug 465307 - System hang on boot
System hang on boot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.0
i686 Linux
high Severity urgent
: ---
: ---
Assigned To: Peter Zijlstra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 13:36 EDT by Clark Williams
Modified: 2014-08-11 01:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 15:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Williams 2008-10-02 13:36:25 EDT
Description of problem:

the system (a Sun x4150 with 16GB RAM) locks during boot, when the rtctl service runs to set kernel thread priorities.

Version-Release number of selected component (if applicable):
2.6.24.7-74.el5rt

How reproducible:
Always

Steps to Reproduce:
1. Load MRG RT 32-bit kernel
2. Boot system
3. system hangs when rtctl service runs

Additional info:

Customer noted that when /etc/rtgroups line for softirq was changed to priority 65 (as opposed to the 70 value that's delivered) the system boots.
Comment 1 Clark Williams 2008-10-09 10:34:04 EDT
It's been noted that this Sun system isn't the only one that has failed to boot the -rt kernel due to large amounts of ram.  Specifically, an HP DL585g5 with 32GB of RAM failed to boot in the perf-lab. 

I'm inclined to elevate the severity of this one.
Comment 2 Clark Williams 2011-02-10 15:53:27 EST
No one has reported this on our 2.6.33-based kernel, so I'm closing. If we hit it again, we can reopen or open a new bug.

Note You need to log in before you can comment on or make changes to this bug.