Bug 465349 - Wacom Bamboo tablet doesn't work at all
Wacom Bamboo tablet doesn't work at all
Status: CLOSED DUPLICATE of bug 109750
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 16:58 EDT by Dawid Pietrala
Modified: 2018-04-11 03:51 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 01:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (900 bytes, text/plain)
2008-10-03 11:15 EDT, Dawid Pietrala
no flags Details
Xorg.0.log (11.89 KB, text/plain)
2008-10-03 11:16 EDT, Dawid Pietrala
no flags Details

  None (edit)
Description Dawid Pietrala 2008-10-02 16:58:57 EDT
Description of problem:

i've just installed Fedora 10 Beta and discovered that my Wacom tablet does not work even as a pointing device. in Fedora 9 it worked without any changes in xorg.conf
  
Actual results:

the tablet has been recognised after plugging-in:

tail -f /var/log/messages

Oct  2 22:53:58 teru kernel: usb 3-2: new low speed USB device using uhci_hcd and address 4
Oct  2 22:53:58 teru kernel: usb 3-2: configuration #1 chosen from 1 choice
Oct  2 22:53:58 teru kernel: input: Wacom Bamboo1 as /devices/pci0000:00/0000:00:1d.1/usb3/3-2/3-2:1.0/input/input7
Oct  2 22:53:58 teru kernel: usb 3-2: New USB device found, idVendor=056a, idProduct=0069
Oct  2 22:53:58 teru kernel: usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct  2 22:53:58 teru kernel: usb 3-2: Product: CTF-430 V2.0-0
Oct  2 22:53:58 teru kernel: usb 3-2: Manufacturer: WACOM

lsusb

Bus 003 Device 004: ID 056a:0069 Wacom Co., Ltd 

rpm -qa|grep wacom

linuxwacom-0.8.0.3-2.fc10.i386

however it does not work at all

Expected results:

it should act 1) as a pointing device, 2) as a device for painting for example in GIMP
Comment 1 Peter Hutterer 2008-10-03 03:19:31 EDT
Please provide your xorg.conf and your Xorg.log file, otherwise we can't really debug this. Thanks.
Comment 2 Dawid Pietrala 2008-10-03 11:15:35 EDT
Created attachment 319376 [details]
xorg.conf
Comment 3 Dawid Pietrala 2008-10-03 11:16:11 EDT
Created attachment 319377 [details]
Xorg.0.log
Comment 4 Peter Hutterer 2008-10-06 20:18:01 EDT
Please add the following line to your /usr/share/hal/fdi/policy/20thirdparty/10-linuxwacom.fdi

<merge key="input.x11_options.Type" type="string">stylus</merge>

This goes right below the line that specifies x11_driver as wacom. Then restart HAL and then X and let me know if that fixes it.
Comment 5 Dawid Pietrala 2008-10-09 15:10:11 EDT
now it works fine however only as a pointing device. thank you!
Comment 6 Matěj Cepl 2008-10-09 17:36:20 EDT
So we need to fix "use as painting device", right? Or are we done here?
Comment 7 Peter Hutterer 2008-10-09 21:21:48 EDT
That's as far as we can get without modification in the driver. I talked to aris this morning so we should hopefully get it fixed properly soon.
Comment 8 Dawid Pietrala 2008-10-11 08:18:08 EDT
(In reply to comment #6)
> So we need to fix "use as painting device", right? Or are we done here?

yes, we still need to fix it. i'll let you know as soon as sth changes. thanks!
Comment 9 Dawid Pietrala 2008-10-20 13:17:07 EDT
i've just found out that unplugging the tablet causes X to crash. no trace in logs, though. should i post another bug?
Comment 10 Peter Hutterer 2008-10-21 02:45:55 EDT
Yes please. I'm suprised there isn't a backtrace or anything. 
Anyway, reassigning this one to linuxwacom, i know aris is/was working on it.
Comment 11 Matěj Cepl 2008-10-22 19:04:35 EDT
(In reply to comment #9)
> i've just found out that unplugging the tablet causes X to crash. no trace in
> logs, though. should i post another bug?

yes, against xorg-x11-server component, attach /etc/X11/xorg.conf, /var/log/Xorg.*.log, /var/log/dmesg, and /var/log/messages.
Comment 12 Dawid Pietrala 2008-10-23 15:51:15 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=468264

submitted. thank you!
Comment 13 Dawid Pietrala 2008-10-27 15:19:34 EDT
after today's update (linuxwacom-0.8.0.3-3.fc10.i386) the tablet ceased to work. i had to repeat the step in #4.

before that however, i copied a part of my Xorg.0.log:

(II) config/hal: Adding input device Wacom Bamboo1
(II) LoadModule: "wacom"

(II) Loading /usr/lib/xorg/modules/input//wacom_drv.so
(II) Module wacom: vendor="X.Org Foundation"
	compiled for 4.3.99.902, module version = 1.0.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 2.1
(II) Wacom driver level: 47-0.8.0-2 $
(EE) Wacom Bamboo1: No type or invalid type specified.
Must be one of stylus, touch, cursor, eraser, or pad
(EE) PreInit returned NULL for "Wacom Bamboo1"
(EE) config/hal: NewInputDeviceRequest failed
(II) NVIDIA(0): Setting mode "1280x1024_75"
(II) config/hal: Adding input device Wacom Bamboo1
(EE) Wacom Bamboo1: No type or invalid type specified.
Must be one of stylus, touch, cursor, eraser, or pad
(EE) PreInit returned NULL for "Wacom Bamboo1"
(EE) config/hal: NewInputDeviceRequest failed

after:

(II) config/hal: Adding input device Wacom Bamboo1
(II) LoadModule: "wacom"

(II) Loading /usr/lib/xorg/modules/input//wacom_drv.so
(II) Module wacom: vendor="X.Org Foundation"
	compiled for 4.3.99.902, module version = 1.0.0
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 2.1
(II) Wacom driver level: 47-0.8.0-2 $
(**) Wacom Bamboo1: always reports core events
(**) Wacom Bamboo1 device is /dev/input/event5
(**) Wacom Bamboo1 is in absolute mode
(**) WACOM: suppress value is 2
(**) Option "BaudRate" "9600"
(**) Wacom Bamboo1: serial speed 9600
(II) XINPUT: Adding extended input device "Wacom Bamboo1" (type: Wacom Stylus)
(**) Option "Device" "/dev/input/event5"
Wacom Bamboo1 Wacom X driver grabbed event device
(==) Wacom using pressure threshold of 30 for button 1
(==) Wacom USB Bamboo1 tablet speed=9600 (38400) maxX=5104 maxY=3712 maxZ=511 resX=1012 resY=1012  tilt=enabled
(==) Wacom device "Wacom Bamboo1" top X=0 top Y=0 bottom X=5104 bottom Y=3712 resol X=1012 resol Y=1012

but it still works only as a pointing device.
Comment 14 Peter Hutterer 2008-10-27 20:19:49 EDT
The workaround is now part of 0.8.0.3-4, but with the same limitations (stylus only). At least you don't have to apply it manually anymore.
Comment 15 Dawid Pietrala 2008-10-28 02:20:36 EDT
(In reply to comment #14)
> The workaround is now part of 0.8.0.3-4, but with the same limitations (stylus
> only). At least you don't have to apply it manually anymore.

well, actually i had to. before that, the tablet didn't work.
Comment 16 Peter Hutterer 2008-10-28 02:25:11 EDT
doh. seriously? are you sure that's -4, and not -3?
did you restart HAL before restarting the server?
Comment 17 Dawid Pietrala 2008-10-28 02:51:46 EDT
(In reply to comment #16)
> doh. seriously? are you sure that's -4, and not -3?
> did you restart HAL before restarting the server?

you're right: linuxwacom-0.8.0.3-3.fc10.i386. sorry!
Comment 18 Bug Zapper 2008-11-25 22:28:55 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 info@kobaltwit.be 2009-01-28 11:29:19 EST
(In reply to comment #7)
> That's as far as we can get without modification in the driver. I talked to
> aris this morning so we should hopefully get it fixed properly soon.

If this is the only reason this bug is still open, I think it can be marked as a duplicate of bug #109750 (or the other way around). Both state that changes are required in the driver to fully autoconfigure all features of the wacom tablets.

I won't mark it as duplicate myself as I'm not the maintainer of these bugs.
Comment 20 Peter Hutterer 2009-03-27 01:48:02 EDT

*** This bug has been marked as a duplicate of bug 109750 ***

Note You need to log in before you can comment on or make changes to this bug.